can't overdub with Behringer UM2?

Hi all,

I’ve only just started using Audacity and am new to recording in general, i’m also not a ‘tech-head’ in the slightest so apologies in advance if this is silly/ already answered. I’ve looked through the forum, google, youtube etc. but can’t find a solution that works, not one that i can understand anyway :confused:

I bought a UM2 and am just trying to overdub simple guitar tracks, i.e solo along with a blues progression. I’m able to record one track fine and play it back without issue, but when i try to record a second track over it an error message pops up saying “Error opening recording device. Error code -9999 Unanticipated host error.”. This happens when i have overdub checked ON in the transport options menu. If i turn it OFF i’m able to record a second track, but don’t get the playback of my original to the headphones.

I can hear my guitar live through the headphones and play along when i playback the first recording, but get the error message when i hit record.
The project rate is set at 44100Hz.

Any idea what the problem is?

Thanks very much,

That happens when the playback side of things isn’t set up right. When you overdub, Audacity has to play your backing track to you and record the new work at exactly the same time. Any mismatch in the system can cause it to crash.

Turn off Direct Monitor. You will no longer be able to hear yourself, but you should be able to hear the backing track perfectly. Can you? Can you play to the UM2 without Overdub selected?


Thanks Koz,

I managed to solve the problem by going through the steps listed here:

I think the problem was that i had playback set to a higher frequency (DVD quality?), as that’s the only thing i had to change. Does that seem likely?

Anyway i’m off and racing now, and learning a lot reading these threads! So thanks very much indeed :slight_smile:


i have another question, thought i would ask here rather than make another thread.
I’m now trying to correct the latency, i’m following the instructions from , but i can’t find ‘Track shift after record’ on my version. Is it called ‘Latency compensation’ on the new version? Or is that something else?


Apologies, sorry that’s my fault (as the main editor of the Manual).

We changed that nomenclature for 2.3.0 - I remembered to change the Devices Preferences page - but totally forgot to fix the latency test page :blush:

So yes it is now called Latency compemsation.

I can’t update the 2.3.0 Manual once it’s been released - but I will fix it for the upcoming 2.3.1 Manual.



And many thanks for that good catch loudog - much appreciated :slight_smile:


No problem, glad i could help :slight_smile:

And i’ve managed to set the latency perfectly now, so many thanks for the clear instructions that even a noob like me can easily follow.



I had the same issue with 3 different windows 10 computers (3 different sound cards) and searching in this forum was the solution !!!
Thanks to Loudog and Waxcylinder

Specially this point is important and alone solved the issue:
Right-click over your desired device again, choose Properties then the Advanced tab, and set Default Format to a stereo choice with the same sample rate you chose in step 6.2 of the “Recording Settings” above.