Can't import m4A

I am using Mac Mojave version 10.14.4 beta

I installed the latest version of Audacity ( 2.3.0 )

I tried importing a song .m4a file and it said the FFmpeg libararies were not found. It also said this version was not compiled with Quicktime support.

I googled the problem and tried several solutions -

I tried downloading the FFmpeg library, but when I tried to install it (drag the library files into the lib folder ) there was no lib folder, it was just an alias file. I even tried creating my own lib folder and manually copying the files but it still couldn’t find it.

I tried deleting the audacity folder contents in the Application Support to rebuild everything, that didn’t work.

I even tried simply putting the downloaded files into the same folder as the Audacity app, that didn’t work.

I’m at a loss as to what to do next.

I had trouble with this when I first started using Audacity. Looking back over my notes, here’s what worked for me:

Go to this page

Where it says 64-bit FFMPEG for Mac OS X, click on Recommended download:ffmpeg_64bit_osx.dmg

Double-click to mount the dmg file after it downloads.

Click through the steps in the installer, accepting the defaults in all cases.

Restart Audacity, if it was open.

(All of this is from the manual

the 64-bit FFmpeg libraries are only for the upcoming 2.3.1 (and subsequent releases) as this will be the first 64-bit build of Audacity for Mac.

For 2.3.0 you will need the 32-bit version which you should find lower down the page on that download site.


That’s because, in the absence og the FFmpeg library, Mac is trying to be “helpful” by trying to use Quicktime - and not succedding.

It’s not a very insightful or helpful error message (and I have logged a bug report for that):


Audacity 2.3.0 is know to crash on 10.14.4 beta (beta operating systms or beta applications are not a wise choice for production work - they are always intended as test-beds).

This issue is fixed in the soon to be upcoming 2.3.1 which will be the first 64-bit build oof Audacity for Mac.


the 64-bit FFmpeg libraries are only for the upcoming 2.3.1 (and subsequent releases) as this will be the first 64-bit build of Audacity for Mac.

For 2.3.0 you will need the 32-bit version which you should find lower down the page on that download site.

I must have downloaded this library before the 64-bit version was posted there. The “external download page” link in your manual takes users to the 64-bit section. Most of us aren’t technically-oriented enough to notice or to even know what the difference is.

Indeed - and that’s why it clearly states in bold letters
Mac OSX 64 bit LAME mp3 library for Audacity 2.3.1 and above:

You don’t have 2.3.1 the current released version is 2.3 0 whuch is the last 32-bit version.

The download page was only changed to put the 64-bit libraries at the top very recently (last Friday in fact). We are in the last stages of preparing for the 2.3.1 64-bit release and therefore we needed to rejig the download site to give prominence to what users are going to need with the 64-bit 2.3.1 Audacity.

We continue to host the 32-bit libraries as we realize that some users may prefer to stick with older 32-bit Audacity versions - but these 32-bit library downloads are, and will remain, further down the page.

BTW if you have inadvertently installed the 64-bit library - it will do no harm to 32-bit Audacity and you will be well prepared for installing 2.3.1 when it comes out with your FFmpeg library already in place.


Indeed - and that’s why it clearly states in bold letters
Mac OSX 64 bit LAME mp3 library for Audacity 2.3.1 and above

I realize you think that makes it obvious to users, but it doesn’t. It may as well be written in Greek. By the time we have already tried other methods of installing these libraries and had them fail for no reason that we can see, our heads are swimming.

It wasn’t even easy for me to find that download page, as I originally followed the instructions given to me by the software itself after I tried and failed to import an audio file.

Here’s all of what I went through, from the notes I took at the time:

When I import audio files, I get the pop-up message, “FFmpeg not found. Audacity attempted to use FFmpeg to import an audio file, but the libraries were not found. To use FFmpeg import, go to Preferences > Libraries to download or locate the FFmpeg libraries.”

When I go to Preferences > Libraries > FFmpeg Import/Export Library, it says FFmpeg library not found.

When I click on Locate, a pop-up tells me “Audacity needs the file ‘libmp3lame.dylib’ to import and export audio via FFmpeg.” But as you can see from the screenshot below, it’s right there! Somehow Audacity knows, and yet doesn’t know, right where it is. And that doesn’t seem like the correct file, anyway, because that is the lame library, not the ffmpeg library, right? Right?

I decided to click the download link to see what that got me. I was taken, through a couple of steps, to this page, which says, “If Audacity does not detect FFmpeg, download the ZIP option, extract the files inside to a well known folder, then open Audacity, go to Library Preferences and configure it to search on the well known folder you extracted the files to.”

Downloading the zip file "Binary FFMPEG OSX Installer” (zip version) got me a file called
I opened this and dragged all the files to Macintosh HD/Library/Application Support/audacity/libs/ffmpeg (I created this new ffmpeg folder).

The problem is, when I went back to Audacity > Preferences to point it in the right direction, I found that it wasn’t enough to point it to this library full of files. It wanted me to pick which file, and there are no instructions on this…

When I went back to the manual, the ffmpeg section there says to download the dmg version. Let’s try that.

So I went back and downloaded the 32-bit version ( I for one DO understand the difference, but then again I have a computer science degree lol)

However, it simply unzipped a folder full of the dylib files, it didn’t include an executable installation program. So, since the current version of Audacity installs the executable file directly into the main app folder, I went to the ~/Library/Application Support/audacity folder and created a libs folder myself, and added the files in there.

It still didn’t work, however. It still cannot find the file.

I just tried once again looking into my folders…not sure where I was looking before, but this time there was no audacity folder in my Application Support folder, so I created one, then created a libs folder and added the files to that folder.

Works now! Thanks!

Yes the guy that wrote the dmg (and who hosts the dowload site) decided to make it that way. The instructions in the text file in the dmg just tell to drag each of the 3 files over into the libs folder in the dmg dialog.


I’m using the latest version of MAC OS on my iMAC and just downloaded the program, but I can’t import MP3,s or MP4’s from my iTune Folder. I downloaded the Library and estarted my computer and nothing works. Does any one have a fix for this problem? Thanks in advance.

Did you get it from here:
If not, then you may not have a genuine, or up to date version.

Which library? Are you referring to FFmpeg?
FFmpeg is required for MP4.
Installation instructions for FFmpeg are here:

I just downloaded the latest version and it is working just fine. Thank you