Can't import EQ curves in Audacity 2.4.1

I use Audacity to restore 78s.

When I updated to Audacity v2.3.3, I noticed that importing filter curves hadn’t been implemented yet, so I reinstalled v2.2.2.

I just tried v2.4.1, but it looks as if what it imports are some kind of .txt preset files – not the XML files I have used in the past.

What should I do if I want to use the sort of XML EQ files that you so generously supply on your website, or ones that I have saved in the past? Thanks!

We have provided (Steve provided actually) a new tool in 2.4.1 for converting XML files to TXT format for use in 2.4.1.

It ships with Audacity but is not enabled by default - you need to enable it with the Plug-in Manager.



Thank you! That’s very helpful.

I also wasn’t able to get the 78 RPM EQ Curve Generator enabled when I was playing around with Audacity 2.4.1. Does that one need to be updated? I do occasionally use it.

I have EQ_toolbox_78rpm.xml file and I enabled the EQ XML to TXT tool. However, when I run it and select the xml file there is no Output file shown on the dialog and no txt file gets written. Am I missing something? There is no way to set the output file name that I can see and the web pages say it will write a new file with a .txt extension using the same name as the original.


In which version of Audacity?

Audacity version 2.4.2. The output file seems to never get created.

Does anyone already have the converted txt file for EQ_toolbox_78rpm.xml? I cannot get the tool to work in Audacity 2.4.2. It outputs nothing at all. If the txt file could be posted or added to the wiki site it would be really great.

All I use Audacity for is transferring 78 records. Without this file, I am unable to use Audacity for that purpose.

Does the plug-in look like this:

To use the plug-in:

  1. Create a new, empty folder somewhere convenient
  2. Place the “EQ_toolbox_78rpm.xml” file into the new folder
  3. Launch the “EQ XML to TXT Converter” plug-in from Audacity’s “Tools” menu
  4. Select “Graphic EQ” or “Filter Curve EQ” depending on which effect you want to use the curve in.
  5. Click the “Select a file” button
  6. In the file browser that opens, locate and select the “EQ_toolbox_78rpm.xml” file
  7. Click the OK button

There should then be a message when the plug-in has run. What does the message say?

Here is the dialog with the file selected.
Screen Shot 2020-06-30 at 8.13.02 AM.png
Here is the results dialog.
Screen Shot 2020-06-30 at 8.13.14 AM.png
And, nothing it written.

How strange.

Please updating Audacity to 2.4.2 and see it that fixes it. (

I am running 2.4.2

Please try this:

  1. “Help menu > Diagnostics > Show Log”
  2. Click the “Clear” button.
  3. Attempt to convert the XML following the previous steps.
  4. Save the log somewhere convenient
  5. Attach the log to your reply.

Nothing was added to the log file after trying the conversion. See attached log file. It only shows the cleared message from before I tried the conversion.
log.txt (38 Bytes)

The problem is not due to you doing anything wrong. There’s something strange about that XML file that is causing the problem.
It may take me a while to work out a fix.

In the meantime, if you or anyone else has a converted file you could send me I would really appreciate it.

Thanks for your help.

The problem is that the “EQ_toolbox_78rpm.xml” file uses the wrong kind of line endings for macOS and Linux (“CRLF” instead of “LF”), and that is causing the conversion to fail.

Here’s the curves from the “EQ_toolbox_78rpm.xml”
BBC Transcription (1949) 2.1.2.txt (8.01 KB)
American 78 2.1.2.txt (7.84 KB)
Telefunken 2.1.2.txt (7.44 KB)
Blumlein300 2.1.2.txt (7.55 KB)
Columbia 78 2.1.2.txt (8.08 KB)
500-FLAT 2.1.2.txt (7.43 KB)
European 78 2.1.2.txt (7.3 KB)
Decca 78 2.1.2.txt (7.9 KB)
Western Electric 2.1.2.txt (7.79 KB)

This is an updated version of the “EQ XML to TXT Converter”.
To update in Audacity 2.4.2 or earlier, you will need to manually replace the current version of “eq-xml-to-txt-converter.ny” with this version (no need to re-enable the plug-in if it was already enabled).
eq-xml-to-txt-converter.ny (5.74 KB)

Wow, thanks for the quick response and fix. Now, I just need to figure out the correct way to import the files. :slight_smile:

Where is the eq-xml-to-txt-converter.ny file located? I cannot find it on my system.

Because it’s one of the shipped plug-ins, it’s in the Program folder.
On 64-bit windows with a default installation, it will be in:

C:\Program Files (x86)\Audacity\Plug-Ins\