Cannot record

Using 2.2.2.
Any attempt to record with any of the settings gives message: Error opening sound device.
Have tried changing audio host/recording device/sample rate. No luck.
Program will load and play midi files and audio files.
Have tried recording via microphone/line-in/auxiliary. No luck
Using SoundBlaster Audigy (don’t know model)

My setup works perfectly with SONAR.

I had the same problem. I could hear the input device via the playback output, but Audacity always displayed the error message when trying to record. I had tried the other suggestions in Audacity Help to no avail. For me, the solution was to change the account privacy settings to allow application access to the microphone. To do this, from the Win 10 Start menu, select Settings (the gear), then Privacy. On the left side panel under “App permissions” select Microphone. Check that “Allow apps to access your microphone” is set to “On” (you can then enable/disable other app access below this setting).

Giving credit where it’s due, the privacy settings solution is discussed in the forum announcement “Microphone problems after the Windows 10 April 2018 Update” by waxcylinder, May 27, 2018.

Hi. I’m new to the forum.
Thanks for this solution. Changing the privacy settings worked for me after months of frustration and acquiring a new sound card.
How do you think this information could be added to the “help” page that pops up when you clic the question mark in the “error opening sound device …” window ?

Thanks for this. I was unaware of those settings, need to spend more time on Win 10’s innards.
Everything fine now.
Thanks again.

I have already done this in the alpha Manual for the soon to be upcoming 2.3.0 version of Audacity.

We cannot change the released Manual(s) as once a release is made the Manuals become set-in-stone and are immutable.