Cannot record since windows update

I have been using audacity 2.1.2 for a while. Yesterday there was a windows 10 update and when I went to record from my turntable I got the message;- Error opening sound device. Try changing audio host, recording device and sample rate. I have been using MME audio host, microphone USB array, 2 Channel stereo, realtech speakers and sample rate 44100.Tried all suggested, nothing worked. Still got same message. In desperation uninstalled 2.1.2 and installed 2.2.2. Still have same problem.

Check that Windows has not turned off/made unavailable uour sound input devices as part of the upgrade.

When mine was updated recently I found that the microphone and stereo mix both had to be reenabled.


Thank you, but I had already checked this and both were enabled. Getting very frustrated.

Finally got desperate and restored computer (Windows 10) back to prior to update. Everything now working great. Do not know what the update did. Any ideas?

My guess is that it is this problem:

Thank you, will file the answer away for when Windows installs the update again. All working well since rollback.