Cannot record analog source in stereo with USB DAC (Windows 10)

I have seen a number of similar queries about this, but nothing that solves my particular problem.

I am using Audacity 3.3.3 on Windows 10
Dell Precision 3510
NAD PP3 USB preamp (DAC)
Nakamichi CR1A Cassette deck

I am trying to backup some old band cassette recordings to digital. I have the line out from the cassette deck plugged into the input of the DAC. The USB output from the DAC is connected to a USB port on the Dell laptop.

I accepted the MME default driver, used Microphone (USB Audio CODEC) (naively, because the input is USB) as the recording device, and Channels: 2 (Stereo). Project and Default Sample Rates are 96000 Hz, and Default Sample Format is 32-bit float.

I was able to record to digital, but I noticed the result was in mono, so I searched how to record in stereo. Several posts in the Audacity Forum and in Microsoft forums said the issue was with OS settings (not Audacity). The solution recommended was to go to the Recording tab in Sound settings, and select Stereo Mix. This is what I did. It was originally set to Microphone USB Audio CODEC, which again successfully recorded in mono, but not stereo. My sound settings are now as shown:


Now, however, when I attempt to record to digital with Audacity, there is no signal – both channels are flat-lined (the Audacity forum won’t let me embed more than one image, so I can’t show it).

In the device panel below, the recording device was still Microphone (USB Audio CODEC), but thinking this might be the problem, I tried the other settings. I tried each of the other two. Microsoft Sound Mapper resulted in the same problem. Microphone Array resulted in an error (probably not a surprise since I’m not using a mic). Just for kicks and giggles, I tried all other possible combinations of driver (Windows Direct Sound and WASAPI) with each recording device setting, but either I got flat lines again or an error.

Also, coincidentally, when I recorded in mono, I could monitor the recording using the Software playthrough of input setting in the Recording options, but when I switched to Stereo Mix in Windows, all I got was hum that increased or decreased with the headphone level setting. This isn’t the primary issue, but I’m just mentioning it for completeness.

Can anyone help me here? It seems other people have had some similar issues, but I haven’t seen anything specific to using a USB DAC with an external analog source. I tried to use the information as best as I could, but nothing worked.

Thanks in advance.

Need to change recording device properties …

Note thgat your USB device is disabled:

Right click on that and enable it - and then restart Audacity or use Transport > Rescan Audio Devices the you should be able to select the USB device as your input device.

I know it says “microphone …USB” - but that’s Microsoft’s doing - it regards all USB input as microphone for some strange reason.

I went through exactly the same yesterday myself (I always forget that Microsoft for some reason always enables by default my USB device for output but NOT for input).


Thank you very much @Trebor and @waxcylinder – both replies helped me solve the stereo issue. If only this were made more obvious in Windows.

Very much appreciated.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.