cannot record a copy of my song

hi all
i am trying to create a chorus effect from my recorded song.
after hitting ‘‘record’’ button the second track appears with only straight lines…no waveform…no sound.

the method i am trying is;

  1. record copy of song
  2. duplicate the copy
  3. pan the duplicates left and right
  4. time shift duplicates slightly forward and backward

but alas i am stuck on step 1.
any advice please.

i am stuck on step 1.

Right. So you can’t record your microphone. What is your microphone and how is it connected to the computer? Do you use the microphone for anything else and has it ever worked for this job? Any job?

You didn’t tell us which Windows you have.

Which Audacity do you have—all three numbers.


thanks roz.

i have windows 7 pro and audacity 2.1.3

the song is recorded and saved in my muslc folder.
i imported it into audacity as track 1.
my plan was to record a of copy track 1. and use as track 2. which would then play back together in unison.

i have not used a microphone in this project.
as mentioned previously track 2 goes through the record process but there is no sound or wave form…just two straight lines.

You don’t need to record a copy of track 1 : you can duplicate it …
Select the track you want to copy , then press “Ctrl”+“D” keys, an identical copy of the track will appear below the original track.

Re: chorus. There is a free VST plugin called Acon multiply, which has some nice chorus effects on it as presets …

Hi, guys!I still can’t believe that I have found an answer to my question! Thanks to all for your precious recommendations!The song has been successfully recorded and saved in my music folder.

thanks trebor for the info re the chorus presets…i will def try this.

however. if i may refer you back to my original post.
i have tried to duplicate the song as track2; and when playing back both tracks together they sound exactly the same.

i have seen a tutorial on you tube where the original is recorded as a copy and playback[both tracks] is a fuller chorus sound because the copy is not a true/exact copy of the original.

the effect can be further enhanced by duplicating the copy [ not original] then panning and finally ; with trim tool , moving track 1 forward a little and track 2 back a little.

so , my problem is…how do i record a copy of my song.


If you have a recording of your song, “Ctrl”+“D” makes a copy of it instantly. Do it twice and you’ve got 4 …
Duplicating twice (2x2=4).gif
BTW other free chorus plugin are available which work in Audacity in Windows …

You’re doing it the the slow & hard way by manually time-shifting multiple tracks by different amounts.

i have attempted to d/l both acon and black cat[both 32 bit]
acon only installs setup wizard…cannot proceed; when i try to ‘‘open’’ it goes back to setup wizard install.

black cat installs but when opened shows 3 options 1. manual 2. web page 3. uninstall
i have tried in google chrome and firefox and also 64 bit versions.

thanks for your description of my song record problem…v good
from what i have learned from you tube the duplicate copy does not work because it is an exact copy ; whereas the recorded copy is not true and therefore the result produces the effect of two vocalists singing the same song.

the duplicated version is exactly the same as the original …only one vocalist.

is it possible to make a recording in audacity?? maybe it is incapable of this.

i acknowledge your comment that this method of producing a chorus effect is the hard way to go about this.


After you’ve created 2 duplicate tracks, you can time-shift them, say +/- 10 milliseconds,
pan one full Left , pan the other full right , then you get a chorus-effect if you mix them with the original …

The chorus plugins can produce richer chorus-effect than doing it manually …

conspicuous-chorus.xml (507 Bytes)
Here’s Steve’s Chorus plugin which is specific for Audacity … Chorus Effect
It’s a Nyquist plugin , here’s how to install those …

i have been trying to install the chorus vst plugins recommended.
both are in my vst plugin folder.
i have moved the multi voice chorus to audacity add/remove but it will not remain enabled,it goes back to disabled after clicking ok.

i cannot move the bluecat chorus to audacity…it does not show in add/remove box.

They both work for me …
Multi-voice-chorus in Audacity 2-1-3.png
Blue cat chorus VST is Audacity 2-1-3.png
You could have this problem … Chordino does not remain 'Enabled' [SOLVED]

i tried your link to the possible solution but could not proceed.

i could not locate the pluginregistry.cfg. after following the instruction User<Username>\AppData\Roaming\Audacity\

if i could find this i will try:

  1. exit audacity

  2. delete effect plugins

  3. reinstall chosen plugins [add/remove location].


“AppData” is a hidden file in Windows.

At the risk of stating the obvious, you have to put your own username in that string without the <> brackets …
one way to see AppData folder.png

‘‘show hidden files and folders’’ is enabled.

i am still unable to find pluginregistry.cfg.

the ‘‘run’’ instruction is followed by a ‘‘location cannot be found’’ message.


If you can make your way to “AppData\Roaming\Audacity” “pluginregistry.cfg” is there, see …
''pluginregistry cfg'' in Windows Vista.png

i did a command prompt and it showed there is a plugintegistry.cfg file in c:disk ; i just cannot find it.

however, i have found out i can delete this via command prompt route.

so, just to be sure i am doing things correctly after deletion, can you confirm:

  1. i exit [not uninstall ] audacity

  2. delete file

3, open audacity and re install plugins of choice including new ones in add/remove plugin manager.


That sounds right to me.

I think the config file will survive uninstalling Audacity, that’s why you have to seek & destroy it.
BTW you can rename the old config file, rather than deleting it , as I have done …

That allows you to put it back the way it was.


i am not sure i understand your last piece of info.
do i :

  1. not go ahead and delete the cfg file via command prompt… and:

  2. rename the cfg file via command prompt

3, if so how do i do this??

will i then be able to locate and load the chorus plugins?


If you delete “pluginregistry.cfg” the data in it will be lost : no way back from that, unless you have a copy of it.
If you rename “pluginregistry.cfg” to say “pluginregistry-old.cfg” Audacity will generate a new “pluginregistry.cfg” when it is restarted.

If in the future you need to reinstate (or inspect*) the old cfg file you have a copy called “pluginregistry-old.cfg”
[ * it’s a list to remind you of all the of all the plugins you’ve installed ]

in ‘‘command prompt’’ i have tried to ‘rename’ and ‘ren’ the file but i get error message ‘‘command syntax is incorrect’’