Build Audacity with mod-script-pipe on Raspberry Pi [SOLVED]

I’ve compiled Audacity 2.2.2 as well as I’ve also run make install. For my installation, the audacity executable is located in /usr/local/bin/. I’ve tried all of the locations to copy to register it with no avail. When accessing the modules dialog, Audacity returns

No modules were found

So far, I’ve tried these locations:


When I execute audacity as root (i.e., sudo audacity) the module is read, but I don’t know which copy of the file is being read, nor how to fix the installation so I can run audacity as a non-priviledged user. Any tips on getting mod-script-pipe to load correctly?

It should work in:


Note that after enabling it in Preferences, Audacity must be restarted.

That location doesn’t work. The only path I can get it to register is:


and ONLY when executing Audacity as root via sudo audacity. I have successfully registered and loaded the module when executing as root. The non-privileged user can’t see the file, probably because of a permissions problem.

You should not need to run Audacity as root.


should also work, but should not require running as root. Is your user account the owner of

I’ve got it mod-script-pipe in:


and the permissions are:

-rwxrwxr-x 1 <user> <user> 409320 Mar 19 13:35
$ ls -al ~/.audacity-files/modules/ 
-rwxrwxr-x 1 pi pi 40552 Mar 19 15:55 /home/pi/.audacity-files/modules/

Still doesn’t work.

and I presume that you are logged in as “pi”?

Yes sir. Sorry for the trouble, and thanks for the help!!

I don’t understand why it only works for you when running as root, so I’ve posted to the developer’s mailing list to see if anyone there has any ideas.

I’ve done some more checking and confirmed the following conditions:

  1. The module only loads when audacity is run as root, and will load if the module is located in either:


  1. The module will not run under the non-privileged user in any location that I have tried. I have confirmed permissions on files in all of the typical locations and am tending toward thinking it’s probably not a permissions problem.

  2. The location in the source where the module file paths are defined is in and about:

/src/AudacityApp.cpp (1275)

I can’t see anything wrong with the code (then again, I’m not a C programmer).

At this point, I suspect that the problem is seeing/loading the module requires a process that requires elevated privileges, although I don’t know what that would be. I’m going to do some checking along these lines, but there definitely seems to be a problem, either with the configuration of my Debian system (probably) or Audacity itself (possible).

What are the file permissions for your “/tmp” folder? (mod-script-pipe requires rw access to /tmp)

Launch Audacity from your normal log-in account, then look in “Help > Diagnostics > Show Log”. Anything in there related to the module?

I have a quite similar issue. I have mod-script-pipe recognized in Preferences > Modules, and enabled, but it doesn’t seem to be loaded. The pipes are not created. Though it worked the first time after installation, it did not work anymore after the computer restarts.

Do you have an idea of what is going on ? :question:

Are you looking in “/tmp”?
On Linux, if mod-script-pipe is enabled (as can be seen in “Edit > Preferences > Modules”, but only after restarting Audacity), then you should see two files in “/tmp”:


The number at the end may be different (that depends on the logged-in user ID).

Yes, that is where I look for the pipes. I have this issue on two computers (Ubuntu & Linux Mint). No specific message related to mod-script-pipe in the logs. If I choose ‘ask’ for the module nothing shows up when Audacity starts.

Ixnay, If you launch Audacity and then open the Preference page for modules, does it say that the module “mod-script-pipe” is “Enabled”?

Yes, it does. (if I choose “Ask”, then if I start again I can read “Ask” in the preferences but actually it asks for nothing)

Like this?

Oh I got the thing… It’s a problem of PATH too, it does not find the module but as the first time I started audacity from the installation folder, he found it the first time and saved it in the preferences. It works again when I start audacity from the installation folder. But now I fall into the same issue as the author of the thread…

Ok I put the module in ~/.audacity-files/modules/ and now it seems to work ! (I didn’t figure out why it does not work in the same folder as plugins) thnk you

“Modules” and “Plug-ins” are different. “Plug-ins” have to go in the plug-ins path, and “modules” have to go in the modules path.
If Audacity is properly installed at:


then Audacity should be able to find files that are in:


However, I would recommend putting the module into:


as this is a “per user” installation and is independent of the installation path of Audacity.