BPM Label Maker won't Upload on Legacy Version?

So, I’m kind of a bonehead when it comes to production -i’m using an older version of Audacity because I prefer the workflow to the newer version. I used to rely HEAVILY on the BPM Label Maker Plugin, but for some reason, I’m not able to upload it in Audacity like I used to. Audacity isn’t recognizing it in my plugin folder for some reason. I’m sure it’s something I’m doing wrong…

Is it possible that I’ve downloaded the wrong file?? Not certain…

Someone please assist! I’m pretty useless without this plugin.


Can you be more specific ?

Around version 3.0.3, Audacity switched from 32-bit to 64-bit by default. This caused a problem as 32-bit plugins only run on 32-bit machines and likewise for 64-bit. Although all Windows versions of Audacity are available in 32-bit, 64-bit versions are downloaded by default. See the download page for details.

Which one is this ?

Note that 3.3.3 includes an experimental Beats and Measures toolbar and timeline and related features are planned for the near future.

Thanks for getting back to me!

So, apparently, I’m using version 2.4.2 -I have an affinity for the workflow of this version or similar. If I recall correctly, this is the version I was using for years and years, before they made the update -There were several things I didn’t like about the updated version, despite its having the BPM label maker onboard (smart), so I thought I could just download the old version and then download the BPM label maker like I did before, but it’s not working like that for some reason…

Here is the version of the plugin I’ve been trying to load up:

Beat Per Minute labels - Programming and Development / New Plug-Ins - Audacity Forum (audacityteam.org)

Install bmp-labels.ny using the Nyquist Plug-in Installer. (Instructions here: Nyquist Plugin Installer - Audacity Manual ).
Note that in Audacity 2.4.2 you will need to enable the plug-in using the Plug-in Manager after the plug-in has been installed.

Right! That’s what I “did”, but for some reason it’s not working:

-I downloaded the very link you sent “bmp labels ny” (4 times, now…)

-Clicked on: Generate> Add/ Remove Plugins -Plugin Manager is there and Enabled, but the “bmp-labels ny” is nowhere on the list for some reason…

-My only logical thought is that the “bmp labels ny” file is in some folder that Audacity isn’t pulling from. I’m guessing that’s gotta be it??

EDIT: Just solved it!!!

-I had to go to: TOOLS> Nyquist Plugin Installer and then that allowed me to go to my downloads folder and upload the “bmp labels ny” file. It wasn’t enough that the plugin manager was already installed - that was not going to track down the plugin for me - I had to go via the Nyquist Plugin Installer via the TOOLS dropdown menu in order to “route-in” that “bmp labels ny” plugin. A bit convoluted/counter-intuitive, but it worked! Now I know for next time…

As always, thank you so much, Steve -You keep this place running and us using Audacity!!!


Yes, that’s an important step.

  • What “Nyquist Plug-in Installer” does (“Nyquist Plugin Installer” in more recent versions of Audacity), is to copy the selected “.ny” Nyquist plug-in into the correct place where Audacity can find the plug-in.
  • Once the .ny file is in the correct place, Audacity is able to find it.
  • The plug-in then needs to be enabled:
    In older versions of Audacity, plug-ins must be enabled manually via the Plug-in Manager.
    In recent versions of Audacity, installed plug-ins are enabled automatically when Audacity is closed and restarted.

This topic was automatically closed after 30 days. New replies are no longer allowed.