Been using for months new error message can't open anything please help!

Im using Audacity 2.3.3 on Mac OS Sierra 10.2.6. After using this for months to mix down audio for my podcast I suddenly can’t open any new audio (or even the old stuff) it is telling me “BLANK is an advanced audio coding file you need the optional ffmpeg library.”
So I’ve tried to download the plug in or whatever to no avail, and I already have my preset settings for Compression/EQ down nicely I’m no audio engineer! Is there any easy fix for this? Thanks for listening!

BUMP! Someone please help I have tried to do this manually, went into the preferences, downloaded the plugin, I have tried everything my EQ/Compressor settings are optimal in my version and I suck at production, this was working great until this happened!

There are about half-a-dozen volunteers here, spread out over 8 time zones. We do what we can.

It seems that Audacity thinks you are trying to open AAC (Advanced Audio Codec) files, which require ffMPEG. Your old files didn’t suddenly change to AAC files. Something else has changed.

First, please try resetting Audacity by following these instructions: but only delete the audacity.cfg file, not the plugin files. DO NOTE DELETE pluginregistry.cfg or pluginsettings.cfg.

If that does not work …

Please tell us exactly what file(s) you are trying to open. The full file name, including extension. How are you trying to open it: with File > Open or File > Import Audio?

– Bill

Sorry wasn’t trying to annoy I thought post was seen and ignored.

So I did what you told me to do, and it didn’t work. I am trying to both import and open these files, a variety of all the audio files I use! They are all .wav and .mp3 format. It’s literally every audio file I have that triggers this error message. I don’t understand why this just started happening, or why the listed fix to download the "library’ isn’t working? its frustrating as hell!

I do appreciate the help though.

If the files are WAV or MP3 they should not trigger that warning and should not require the ffmpeg library. Installing the library will not help.

You say this happened suddenly. That means that something changed. Any idea what that might have been?

After doing the reset (by deleting the audacity.cfg file) did you get the welcome screen the next time you opened Audacity? If you didn’t get the welcome screen that means you didn’t reset preferences.

I’ll see if anyone else here has any suggestions.

– Bill

Download this test file (it’s a 6 second tone in WAV format)

Launch Audacity, then “File menu > Import > Audio” and select the downloaded “tone.wav” format.
Does Audacity import it successfully?

You understand you have conflicting symptoms, right? That’s why there’s a sea of questions marks over the land.

Do you know the files are all .wav and .mp3 by reputation, or can you actually see the filename with the dot and three letters? You can hide extensions on Macs, but it’s not recommended. It causes all sorts of problems on Windows.

Right-click or control+tap on one of the files > Get Info.

The actual, real filename is listed.

Screen Shot 2020-06-27 at 8.56.43.png

There is a pure evil version of this extension thing. Someone started offering picture and sound files to everyone named things like CoolMusic.mp3. The filename was really CoolMusic.mp3.exe. Windows would hide the last extension, the .exe part. This was a Windows executable file which would then take over your computer and demand ransom to get your files back.

Hiding extensions is not recommended.


Ok, so the tone.wav opened. Also, a lot of the file extensions I am importing are M4A. The only thing that has changed is I got a new phone after my last was stolen, but Audacity can no longer open all of the files I originally imported into it to edit?

OK, so you can import WAV files. The fact that you are having problems with M4A files is significant, and new information for us. The new phone is probably irrelevant - something has changed on your Mac. Did you update Audacity from version 2.3.0? Versions after that require the 64-bit version of the FFmpeg library.

To import M4A files you do, indeed, need the FFmpeg library.

Please go to the Help menu > Diagnostics > Show Log. Click and drag through the entire contents of the “Audacity Log” window. Right-click and select “Copy” from the dropdown menu. Paste the log into a message here.

– Bill