Basic problem with Wave Out or Stereo Mix

I don’t think tutorials can deal with my issue since i just downloaded audacity, i went to

which talks about the audacity menu having a ''dropdown menu with a mixer toolbar, with ‘‘Wave Out’’ or ‘‘Stereio Mix’’ as the input source.

But the Audacity I downloaded, 1.2.6, of which I have a screenshot here:

doesn’t have any such dropdown menu, only a bunch of faded out options, coupled with a few options that in no case talk about ‘Wave Out’ or ‘Stereo Mix’. In fact, all of the drop down menus on that screenshot don’t open up to either anything or when they do don’t include any of these options.

My question, for which I’d enormously appreciate a response, is where do I click on these options to start recording my PC’s sounds. And since I can’t find these drop downs, there’s nothing I can do with my Vista’s inputs or outputs or whatever until I figure out where on earth these drop downs are. Thanks!!!

For a start I’d recommend using 1.3.12 the latest Beta version - it is the Audacity renmmended version for Vista - see:

Then, what you get in that drop-down box is entirely dependent on your computer, your sondcard and its associated device drivers - and if you are using an external USB soundcard or turntable, then usually that box is blank anyway as the USB device has control.


Wave-Out and Stereo-Mix are normally selected in the Windows Control Panel and it depends greatly on which Windows you have. The majority of XP machines have this listed as a matter of course. In Vista, they may be listed as Extra or no longer supported tools – or left out. Many Win7 machines don’t support that at all.

On newer machines, it’s not unusual to need an external USB device as above and cross the analog cables to record computer sound or internet shows.

The other way you can do this is with a money-based product like Total Recorder.


The following is the solution I found while writing up the follow up question as to why it still wasn’t working with me. The solution is in the Total Recorder manual, where it says ‘‘if the playing back of the sound you are attempting to record was started before Total Recorder was started, the playback program does not use the Total Recorder driver’’. Now, pcs are very cumbersome, and i’m a train wreck with them, but really, how was i to kno, lol.
The issue remains completely with Audacity though, because there seems to be no driver, or device, whatever the difference between these two terms is, that is compatible with WinVista, or at least mine. On Audacity, there are two server options, Windows Direct Sound and MME, whatever they are. and then a bunch of device/driver options which my PC has, my loudspeakers, the Total Recorder loudspeakers, and Realtek and HDMI outputs. This is for playback, and Audacity is capable of playing any mp3 you put in it. However, in the recording section, it has a non existant Total Recorder Microphone, a DigitalIn, and a Microsoft Sound designator (?) Input, all of which fail to recognise sounds from my PC. The last effort, to perhaps get it to recognise the Total Recorder WDM driver and record that way, also failed for Audacity. You guys mentioned a sound card connected to the PC via USB, and I didn’t even know those things existed, all the ones I’ve ever used were built in. And then crossing cables was a term I wasn’t sure what it meant, did it mean literally cutting away at the loudspeaker cables and sticking them in different places?

I’m keeping up each stage in my journey to discovery below in part to attain immortality, and in part because it’s only half solved, in part to motivate myself that I’m not extremely useless, and only perhaps nearly extremely useless when I spend day after day with minor technical problems… oh i wish i could lol…

Thank you very mcuh for your responses. However, I am still failing. My pc is a Microsoft Vista Home Premium. MY soundcard seems to be a Realtek Digital. I updated and installed the 1.3.12 beta version, and now the drop down menu has one option, ‘Master’, but when I try to relate it to the Master on any other pc sound I’m trying to record, it percieves nothing. There are also no other options apart from ‘Master’.
I also installed Total Recorder, and I’m also failing at that. The problem once again, is quite basic, so basic, I can’t find a way to relate it to any of the issues discussed in any of the manuals I’ve read. I can’t relate the Total Recorder device sound to either the Realtek Digitals or the sound that comes out of my loudspeakers, as illustrated in the following screenshots.

The OS is in spanish, so if I may translate, the first screenshot shows how the ‘altavoces’, loudspeakers are getting reception, probably because I’ve selected it as the predetermined driver. The Realtek digital output and HDMI outputs are getting none, like my sex life, but at least when I click on the HDMI output I can configure its loudspeakers. This may be because, even though the HDMI out is apparently broken after just one day’s use a few days ago, it seems to think an outgoing cable from the HDMI on the graphics card may lead to some loudspeakers. On the Realtek Dig and the Total Recorder Loudspeakers, however, there are no loudspeakers to relate to and configure.

In Total Recorder I installed the device it recommended for Vista users, but I can’t seem to find the way to channel the sound into these loudspeakers. One way I haven’t tested would be to set them as the predetermined device and rebooting, instead of just putting them as the predetermined without rebooting, but at this stage I doubt that is the problem. Perhaps eliminating the above loudspeakers could do so something, by ‘deshabilitando’, inhabilitating, but I vaguely remember once when I did that and the thing just disappeared and I can’t remember how or when I got sound back on my OS.

The second screenshot shows the dropdown option on the menu that relates to ‘‘grabar’’, ‘‘recording’’, on my Windows Control Panel’s OS. Here things are even worse, and the línea de entrada and the DigitalIn, whatever they are, show no sound that I am listening to in the loudspeakers we saw in the first drop down. At least the entry line isn’t connected, while the DigitalIn supposedly is, and the DigitalIn is set up as predetermined. Add epic failure to epic failure, and Total Recorder seems to have associated all its recording prowess to a non-existant microphone, instead of my PC.

My device or driver administrator, whatever the translation is in english, show a new driver, the Total Recorder WDM driver, added to the Realtek High Definition audio one i already had, and a Hayppage WinTV I must have installed ages ago.

The manual of Total Recorder gave me a few hints as to where the problem may be

''Sound is reproduced but Total Recorder does not record it. The slider remains at the left edge and the “Length (sec.)” counter does not change.

Possible Cause #1

Some programs have the ability to select the necessary audio driver manually and ignore system settings.

Action #1

Read the program manual and set the Total Recorder driver as both the driver for playing and recording.

See also. Setting playback and recording devices for some applications.

Possible Cause #2

The mode “Auto switch Total Recorder’s driver off when Total Recorder is not active” is turned on (see Driver Settings). In this case, if the playing back of the sound you are attempting to record was started before Total Recorder was started, the playback program does not use the Total Recorder driver. You have changed playback or recording preferred device either manually or it has been done after the play back was started.

Action #2

Without closing Total Recorder, close the playback program and restart it. Try to make your recording again.

Remember if the mode of automatic driver switching is turned on, you should start Total Recorder first and only after that should you start the playback program from which you are going to record sound.

Possible Cause #3

You need to make sure that the audio stream passes through the Total Recorder driver instead of through the soundboard driver. Usually, you can set the Total Recorder driver as your default audio driver, and the system should move the Total Recorder driver to the top position in the device list. Sometimes, this doesn’t happen.

Action #3

Take the following steps:

  1. Select the “Control Panel-Sounds and Audio Devices, Audio" tab (or similar if your operating system is other than Windows XP);

  2. Manually select a real audio device as your default device, and press “Apply”.

  3. Select the Total Recorder driver as your default driver for playback and recording, and press “Apply”.

  4. Close the dialog and open it again (“Control Panel - Sounds and Audio Devices, Audio” tab).

If the Total Recorder driver moves to the top of the device list, this problem should be resolved.

After following these recommendations, you should restart Total Recorder.

Possible Cause #4

Total Recorder’s driver perceives a sound stream in main wave-format (PCM, pulse-coded modulation) only. If the reproducing program sends a sound stream in any other format (e.g. compressed), Windows usually calls the decoding drivers itself to perform all of the required translation. However, if your sound card can make some translation at the hardware level, then Windows can direct the sound stream to the driver of such a sound card immediately, and bypass Total Recorder’s driver. As a result, sound cannot be recorded.

Action #4

Select “Start”-“Settings”-“Control Panel” (for Windows XP select “Start”-“Control Panel”)-“Multimedia” (or “Sounds and Multimedia”, or “Sounds and Audio Devices”) (or from the Total Recorder menu, select “Options”-“System” and check the box “Use preferred devices only”). This eliminates the use of any device other than the default one.

If the previous recommendations did not help, try the following:

Action #5

Try to record in “Sound board” mode from a line such as “Stereo Mix”, “Wave”, “What U hear”, or similar. Most sound boards have such a line.

See also. Using Automatic Recording Level Adjustment.‘’

I’m going to take advantage of the fact I have this thread here, and your experience with Total Recorder to ask a question about recording with it. Though it belongs to another forum, at this stage, I thought maybe you might know, and I’m going to post it elsewhere, so no worries if you don’t.

This one’s borderline paranormal. A fragment of BS Player movie or whatever records normal on Total Recorder. But when I tried to tape a Brain Wave Delta it came out completely different to the source. The source was completely levelled out with no irregularities in dB or Hz, imagine it. And this is what I got as a result in the mp3 i created with Total Recorder, in the attachment folder.

You might find something useful at the link below:

The link is the Google search results for “Realtek” and “stereo mix” at this web site:

I now use Windows 7 but formerly used Vista and fought the driver wars on Vista. You may be able to find a workaround in those search results that will allow you to use stereo mix and Audacity and Realtek sound.

I had Vista and stereo mix going OK with Audacity, but I did not have Realtek audio, so I can’t say how much success you might eventually have.

I would generally advise you to go to as they might have more insight.

My experiences with Total Recorder are tangetial. I do own a license for it – on Windows 2000 machines. They are very clear on their web site that they have sound management on modern Windows machines and people on the forum have gotten them to work.

Macs have different problems and different solutions.