AUP files missing audio data


I am currently using Audacity 2.0.3 on a windows home 7 system. I used audacity to record interviews and saved them as aup files. I am trying to open them with audacity but when I try to it states that audio data is missing. I cannot imort them into audacity because it says it does not recognize the file. I have not tampered with the au files. In addition I have another aup file that will open in audacity but I have been trying to export it as a wav file and I have not been able to.

It’s bothersome when people tell us they saved an “aup file” as if it was a sound file. It’s not. It’s the pointer to the similarly named _data folder which actually has the show in it divided up into small fragments. The _data folder and the aup file need to be in the same location or folder for the show to open. They need to see each other and they have to be exactly the original name when you saved them. Do you have both file and folder?


I apologize for using the wrong terminology, but I have little knowledge of audacity and I am not tech savy. I am just using audacity for a project. I have a file folder in which the au files are in and a project file. These two are in the same folder. I hope that makes sense

the _data folder and aup file are in the same location.

Please attach the AUP file that you cannot open ( please see here for how to attach files ).

What is the exact error when you try to save the WAV from the other AUP file?


Unfortunately I cannot attach the aup file that I cannot open because the audio is confidential data for a research project that I am working on. I cannot open the file and when I try to import it, it states that the file cannot be recognized.

When I was trying to export the aup as a wav, when I clicked on file I was not able to click on the export button (it was gray).

The AUP file is not audio data. It would disclose no more about your project than the screen shots you posted.

However from the other information you give, you will need to restore your missing audio data block files to the project (these are the AU files in the “focus1_data” folder). If you click the “Show Log for Details” button in the message, this will detail the missing files that Audacity is looking for. If you search your computer for some of those this will probably enable you to find where all the missing files are. If you then move them back into the correct “d” folder inside the “focus1_data” folder, then the project will open correctly.

You cannot File > Import > Audio and choose an AUP file because AUP is not an audio file like WAV. It is not very user-friendly but this is how it works - you must File > Open the AUP.

Press the yellow STOP button ( please see Audacity Manual ).


Well it both isn’t and is user-friendly :slight_smile:

The non-unitary structure may not be obvious but it was developed that way for speed of processing. Our users would be very unhappy and find Audacity very use-unfriendly if common operations took a lot longer :sunglasses:

This page from the Manual explains about the project file structure: Audacity Manual


I meant the fact that Audacity plays dumb when you try and import the AUP file rather than just go ahead and open it in a new window.

And it should let you drag an AUP file in, similarly, and have it open in a new window.


You will probably recall that I am one of those who firmly believes that a strong distinction should exist between open/save and import/export - imo:

  1. Open/Save should only be usable on native format files/file-structures - in Audacity’s case that means Audacity projects

  2. Import/Export should operate only on non-native formats e.g, WAV, AIFF, Ogg, Mp3, FLAC etc

It can be quite dangerous to let users think they are “opening” a WAV or MP3 file for editing, which they are not. It encourages them to think they can directly edit said WAV or MP3 file.



Thank you Gale for all of your help. I have clicked the show log for missing details. I am unsure of how to look for these files on my computer. I also do not understand why the files are missing if I have not tampered with any of the au files. I have recently attempted to string the au files together by opening up each au file and copying and pasting them in order. Would this work? I have also attached the aup file.

Thanks again!
focus1.aup (34.1 KB)

You can call File > Open WAV “import in a new window” if you wanted to (that’s what it does). But given the distinction is lost on most people, there seems no need to force them to the extra step of File > New before File > Import.


OK, though you actually attached a PNG image with a LOG extension, which makes computers think it’s a text file.

I don’t need a new log file, but for reference, after opening Help > Show Log… click “Log” at the top (you can press ALT on your keyboard to make it stand out) then choose “Save…” from the log menu. This saves a text file containing the log entries.

The AUP file shows that Audacity is looking for 218 AU files, and you are missing 218, so it cannot find any of them.

So you need to find those AU files. They should have been in a “d00” folder, which itself should have been in an “e00” folder inside the “focus1_data” folder. The first 256 AU files (so in your case, all the AU files) must be in the “d00” folder. If the AU files are in “e00”, or in a “d01” folder in “e00”, the files won’t be found and Audacity will say they are missing.

Yes, if you dragged in first all the AU files from the left channel in the same order as the AUP file, so “” then “” followed by “”…, strung them end-to-end, and then repeated the process for the right channel.

But it’s less work to put the AU files where Audacity is expecting them, as per above. If they actually are where Audacity is expecting them, then something (perhaps a permission problem) is stopping Audacity opening those files. If this could be the answer, try logging in to the computer as an administrator, or put both the focus1.aup and focus1_data folder somewhere you have full permission, such as your Desktop.

Click the Windows globe bottom left. If you wanted to find all AU files, type in the Search box


then click “See more results” which opens Explorer. If you want to search a specific location, click that location in the sidebar on the left then type *.au again in the Search box top right.

If you wanted to search for a specific AU file such as, just type in either search box (and click “See more results” if necessary).


So I tried copying the focus1_data folder to the desktop and opening the aup file in audacity from that location, but I got the same error message.
Do you think that logging on as an administrator might allow me to open the file?

All of the 218 au files are in d00, which is within the focus1_data folder, which is within a folder of the same name (which is also where the aup file is located).
Does it seem like anything is wrong with the location of the files?

If logging in as an administrator does not fix the problem then it seems the only other option is to string all of the individual au files together.

Probably not, if you have permission to open files on that desktop now.

As you describe it, yes.

You want:

[Folder "focus1_data"]
contains [Folder "focus1_data"] and "focus1.AUP" 
         contains [Folder "e00"]
                  contains [folder "d00"]
                           contains "", "" ...