Audacity won't start but will if log on as different user

A few years ago Audacity on my iMac stopped launching. I have tried numerous times to reinstall with new versions and delete all configuration files to no avail in ~/Library/Application Support,
~/Library/Application Scripts
etc etc
I have just installed version 2.3.3. on Catalina 10.15.4 and know there are recording issues.
However it still fails to start with icon appearing very briefly in task bar
Console gives me:
May 5 17:09:48 RichardsiMac10[1] (org.audacityteam.audacity.21536[5042]): Service exited with abnormal code: 255

However if I log on a guest or a test user, Audacity launches correctly
Any suggestions?

With no other data than that, I’d say RichardsiMac10 doesn’t “own” the places that Audacity needs to step in order to launch.

Console gives me…

It makes me nervous when someone posts with console familiarity. That could mean they inadvertently created a System conflict and it’s going to take All The Kings Horses to fix it.

I can make it worse. You’re not the only user on your machine and that’s why the ownership is scrambled.

Did you chown something that you should not have?

Do you use Cloud Storage in any form? iCloud?


I’m running Mac OS X Mojave (10.14.6). - After installing Audacity 2.3.3, the app was launching normally and working great for several weeks. - But since last Friday, I am having the exact same issue as posted here by DickBowyer. - When launching Audacity, the app instantly closes - even BEFORE showing the normal Audacity logo. - The Console System LOG indicates the following error most frequently:

May 6 16:35:40 My-MacPro-Studio[1] (org.audacityteam.audacity.176464[26845]): Service exited with abnormal code: 255

I’ve attempted all of the usual troubleshooting (ie: removing preferences; fully uninstalling and reinstalling, etc.) - After reading DickBowyer’s post, I also created a temporary test User Account with Admin Privileges - and when logged into the test account, Audacity launches totally normally.

BTW - Note to kozikowski, a reference to errors from Console logs should not make you nervous. It’s a basic troubleshooting resource for these kind of issues. Posting relevant error messages often helps in finding a solution.

Thanks in advance to anybody who can help!

BigShowGM “Snap”, sounds like you have exact problem to me

a reference to errors from Console logs should not make you nervous. It’s a basic troubleshooting resource for these kind of issues. Posting relevant error messages often helps in finding a solution.

It also indicates an advanced user and greatly expands the list of possible problems/solutions.

since last Friday

Was that a Mac Update? Check in the logs. App Store notes?

iCloud or other on-line storage? Do you have Guest User enabled? Is Users and Groups locked (or was locked)?


Service exited with abnormal code: 255

Appears to be the machine’s warning that “There’s Something Wrong!”

Not all that helpful, but there are a number of hits for this error from people having their SSH fail. Do you log into the Mac from a remote location? I know that’s a stretch, but that does connect into that whole Permissions/Users thing.

You can have odd Audacity behavior by installing poorly made plugins. There are instances of that creating serious stability problems.

Do you use specialized plugins? We had one failure from someone who thought it was a terrific idea to load All The Plugins On Earth and Audacity went into the mud trying to deal with that.

This is where it turns out you’re both amateur radio operators and using the same Auto Morse Code plugin, for example.

Does it continue to work if you give your New and Improved User ADMIN privileges?


No plugins that I know of.
No morse code plugin
Audacity works fine if new user created with admin privileges and run under that login

Why are you creating users with admin privileges? User accounts should have normal user privileges.
If you installed Audacity from an account that had admin privileges, then that is probably the cause of the problem.

If you read the thread Koz asked if Audacity would run from an alternate user with admin rights. I can confirm Audacity will run as a new user with or without admin privileges and also as a “guest” but not under my user login

What happens if you Right click on Audacity in the Dock and select “Open”? (with your normal user account)

Same answers for me as DickBower - nothing changed with my OS X between the time Audacity was launching and when it stopped - I used Audacity on a Friday afternoon - then shut down my Mac until the following Monday morning. - No updates, no installations, no system or preference changes - just logged in normally and discovered Audacity wouldn’t launch. -

In case it is useful, I did have an older version of Audacity installed at the same time as 2.3.3, and may have launched the older app before this started happening - but in the course of troubleshooting the 2.3.3 issue, I have since removed ALL versions and reinstalled only version 2.3.3 - but the problem persists - Audacity will only launch if I log in from another User Account (admin/standard/guest).

Right clicking the app from the dock, and selecting “Open” - (as suggested by steve) - nets the same results. So, it isn’t a Gatekeeper issue. Also the app technically isn’t “crashing,” it’s “exiting” - and since fully removing and reinstalling it doesn’t resolve the issue, I’d guess the problem lies with a corrupted preference file - or perhaps the code is calling for a reference to denied permission location? - Regardless, can somebody clue me in on where all of the little bits of the app are located? - I must have missed a file or two that needs to be deleted…

Thanks in advance for your help!

On macOS the Audacity Preference files are in

~/Library/Application Support/audacity/

“audacity.cfg” is Audacity’s preferences.
“pluginregistry.cfg” holds plug-in registrations.
“pluginsettings.cfg” hold plug-in settings.

Deleting these three files sets Audacity back to factory settings.
The files are recreated (with default settings) when you next launch Audacity.

Note: Ensure that Audacity is fully shut down before moving or deleting these files.

“audacity.cfg” is Audacity’s preferences.
“pluginregistry.cfg” holds plug-in registrations.
“pluginsettings.cfg” hold plug-in settings.

I would be tempted to save those files on a thumb drive. Air Gap Isolation. If Audacity comes back to life we have zero idea what caused the problem and zero idea where to start looking without access to those files.


And before we ride off in all directions, “Allow user to administer this computer” is not the same as root.

Screen Shot 2020-05-14 at 16.48.47.png
Screen Shot 2020-05-14 at 16.50.06.png

Thanks for the quick reply - Unfortunately, I trashed the same files you suggested early on in my trouble shooting. - But I should be able to restore them, via Time Machine Backup, if that would be helpful…

Meanwhile, since clearing all of the Audacity files and reinstalling a fresh copy of the app several days ago, the Audacity folder (~/Library/Application Support/audacity/) has been pretty sparse - see the attached screenshot - It would seem that the app is exiting before creating the new pref files.

I’ve also attached the current cfg file - but, it too is pretty slim…

BTW - I am familiar with the differences between an admin and the root user - did you mean for me to activate the root?

Thanks again, I’m grateful for the help!
audacity.cfg (185 Bytes)
Screen Shot 2020-05-14 at 8.01.55 PM.png

did you mean for me to activate the root

I did not.

Desktop > Go > Applications > > Right-click or Control+Tap > Get Info.

Screen Shot 2020-05-14 at 17.45.42.png
I may have one more folder layer than you do, but that’s the idea.

We may lose Steve for a while. It’s 0230 where he is.


Is Amazon Cloud Drive active right now? Do you use it for any Audacity jobs? How does that service appear to you?


Here’s the get info on Audacity.

As to the Amazon Cloud Drive - it’s for off-site file storage for our security camera. Access is through a web browser or via a syncing folder on my local drive. - I have a few other cloud based accounts (ie: dropbox, iCloud, etc…), but none of them are used for Audacity jobs.

In case it helps, I do have a slightly unusual setup for my admin account home folder - I have a Late 2013 Mac Pro (trashcan model) and the internal drive space (1TB) is too small for my needs - So, the OS and applications are all stored on the internal SSD - while my home folder, documents and data are located on an external 18TB Drobo Drive. - I’ve had it that way since 2013 without issue - including many previous versions of Audacity.

I verified that I can recover the Audacity Preference files from before the problem began, via my Time Machine backup - would seeing that be helpful?
Screen Shot 2020-05-15 at 1.56.07 PM.png

Saga continues.
Audacity now reports error on attempted startup in 2.4.1 just installed. See attachment image. Can still run under another user (standard or admin) or guest. Is there a guide somewhere to completely uninstall audacity and all configuration settings etc as there must be something specific to me as original user?
Screenshot 2020-05-24 at 11.49.24.png

Ok maybe I am a little nearer understanding problem but not solution.

I boot my mac from a SSD
My home user directory is on the hard disk where I store my data etc
My applications are automatically installed in applications folder on SSD whether logged in as myself or new user

When a new user is created, home folder is created on SSD
Running audacity as new user creates application support folder and plist file in new user home folder library folder (in application support and preferences)
Audacity runs normally

When I run audacity for the first time as myself, the audacity application support folder is created in my user home library folder (on the hard disk) but audacity then stops with “Audacity start up failure” The one file created is audacity.cfg with no session data nor plist file in preferences.

The audacity.cfg file reads:

TempDir=/Volumes/Macintosh HD/Users/dickbowyer/Library/Application Support/audacity/SessionData

Installing audacity to applications folder on HD produces same crash.

So if audacity installed on boot disk with user home folder on same disk runs fine it seems.
If audacity installed on either boot disk with user home folder on different disk or installed on non-boot disk with user home folder on same disk, it fails to complete creation of audacity application support folder/contents and plist file.

Can anyone suggest a solution please?