Audacity will not record after latest OS X update (Mojave) [SOLVED]

Having just updated to OS X 10.14.1 I find that I am unable to record using Audacity 2.1.3.
I am attempting to record audio from my iPad using a Numark USB Audio CODEC device connected to the iPad headphone socket and a USB socket on my MacBook Pro. Prior to the OS update I have used this successfully many times before.
I record using the following sequence:
Connect up hardware as described above
Open Audacity and check that USB Codec Device is shown as the input
Cue audio and set volume on the iPad
Click Pause then record on the Audacity application then click pause again to begin recording
Click play on the iPad
This would normally show the audio trace and allow me to listen to the output using play through.
Now when recording there is no audio trace and no sound output.
I have checked the output from the iPad using headphones which is working normally. I have also checked for audio output on the Mac using previously saved Audacity recordings and again this is working normally.
Can anyone suggest what is going wrong or have Apple now prevented recording due to this being a 32 Bit application? If so, do we know hen Audacity will release a 64 Bit version of this application?

If you go to System Preferences > Sound > Input, can you select the USB Audio CODEC? If you play something from the iPad through the USB input do you see an indication on the level meter?
– Bill

Didn’t Mojave (and Windows) throw an additional security step in there before it would connect to an external device?

You can also Apple (upper left) > System Preferences > Sound > Input (or something similar) and see if the device is connected and shows sound. This must work before Audacity sees the sound. Audacity gets sound from the computer, not the device.

Koz

Yes. By default, Mojave denies programs access to the microphone (any microphone or other audio input device).
The setting is under “Security & Privacy” settings.

See here for details: No signal from USB turntable (Mojave) [SOLVED] - #6 by SonArc

Thanks for the suggestions, now up and running again with Audacity recordings.

What fixed it?

Much earlier OS’s had that, but lately, it’s gotten much more detailed.


Screen Shot 2018-11-13 at 14.22.27.png
Koz

Steve,
I did two things

  1. In System Preferences I navigated to Security & Privacy, Privacy and ticked Audacity, which allows the application to access the microphone.
  2. Also in System Preferences, Sound, Input I highlighted USB Audio Codec. Step 2 was done with the audio source (iPad) connected to the MacBook Pro via the USB Audio Codec device.
    I hope this is clear.
    Jim-H

Thanks for the follow-up Jim-H. Nice to have the solution for other users to find :slight_smile:

I’ll close this topic as SOLVED.