Audacity very jumpy on playback [Big Sur 11.2.3]

Dear all,

I have just upgraded to Big Sur 11.2.3, as my Mac was struggling with pretty much everything.

My old version of Audacity wouldn’t open, so I deleted it, and installed the new one, 3.0.0.

When I am playing back sound, trying to edit, instead of the vertical line moving smoothly from left to right, it’s very jumpy, almost bouncing along, making edit very difficult.

Is this a known issue? Is there an easy way I can get the smooth line back? I am producing podcasts professionally, and kinda need this to be easier than it currently looks!

Many thanks for any help you can offer.

Right-click on the Audacity app and choose Get Info. In the Get Info window, check “Open in low resolution”. Does that help?
– Bill

Hi Bill,

Thank you for your reply. I tried that, and whilst it’s better than it was, it’s still not the same as in the older version of Audacity.

In low res, the jumps are a lot quicker, so it’s much improved, and I can work with it - so thanks! - but I wish I knew how to get that smooth movement again. That was on the very first version I was using in 2007 - I can’t understand why it’d disappear.

Hoping someone has a cure!

Thank you again,


The issue is updating a Mac 30-bit display. So when you updated your Mac, the issue appears. I use the low-resolution setting all the time now.
– Bill

Thank you for your help, Bill.

Hi I just noticed the same issue with audacity 3.0.0 & 3.0.2, on a M1 Mac Mini with 8 GB of ram running Big Sur 11.2.3.
It was weird to me because it was fine a few weeks ago and I didn’t change anything… well, except the monitor (replaced an old 24" 1080 with a 32" 4K) which I didn’t even think could be a factor since every other app performs the same as before.

Now I understand from the comments that it is most likely related to this, so I tried the low resolution option and I can confirm the behavior is much better indeed.

However, the graphics are not so great anymore, obviously, which is too bad when you just bought a 4K monitor :slight_smile:
This is also confusing as OP says the issue appeared after upgrading to 11.2.3, and it doesn’t seem like he changed anything on the hardware side ? I’m surprised older version of audacity / macOS produce better results than newer versions ?

So is there something in Big Sur that is more demanding than before regarding graphics ?
Most importantly, is this something you can fix in future versions of Audacity ?

I’ll use the “low resolution” option for now, but it would be great if we can have this behavior with high res graphics.

Thanks !

Oh and I forgot, I initially ran “Activity Monitor” while doing playback, trying to figure out if it was a performance issue, and I noticed CPU at 100% with a simple playback, so I was very surprised. Not sure if this is expected ?

No, that’s not expected.
During playback I typically see Audacity peak at around 5% and settle at around 3% CPU.

I am seeing the same issue for Audacity 3.0.2 on M1 MacBook Air with macOS Big Sur 11.3. With both high-res enabled and disabled, the vertical line is somewhat jumpy and the CPU usage during playback reaches ~95% on high-res and ~45% on low-res.

I have recorded a video with Audacity and Activity Monitor in hope they might be helpful:


Hi, that’s weird.

I upgraded macOS from 11.2.3 to 11.3.1, the “Open in Low Resolution” is still checked in Audacity GetInfo window, and yet it’s back to high res… and not “jumpy” anymore ! I’m not 100% sure it’s prefectly smooth but it’s definitely a lot better (maybe if we compare side by side with an instance running very smoothly we will see a difference, but it’s very acceptable)
However CPU is still around 90% during playback

So all in all, the upgrade to macOS 11.3.1 seems to have solved the issue for me (?) and on the other hand the low resolution option seems to be ignored now.

Interesting, can’t confirm from my side. On macOS 11.3.1 I still see the difference between low-res and no low-res, and on high-res it’s still jumping 2-4 times per second only if I zoom in to see around 10s of the song. How quick it is for you now if you zoom in to similar levels?

THANK YOU for the low-res information. I just set up my new iMac and had the same issue; low-res solved it for me. Take care, all!