Audacity unexpectedly quit

Back when I was running Mac OS 10.7.4 and upgraded to Audacity 1.3.4, every time I launched the application I would get a message saying “Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog.” However, when I clicked OK on the message, Audacity would crash with the message “Audacity quit unexpectedly.” I tried creating a Temp folder in the Audacity application folder to no avail. Nothing I tried would work. I got so frustrated I just stopped using Audacity and deleted it from my system.

Yesterday, I upgraded my system to Mountain Lion 10.8 and installed Audacity Unfortunately, I am experiencing exactly the same behavior. Attached you will see the complete error report generated by Audacity.

Here is an overview of my system:
Model Name: Mac mini
Model Identifier: Macmini3,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MM31.0081.B06
SMC Version (system): 1.35f0
I have a 370 GB internal drive for the OS, with two external Iomega USB drives–one is 1TB the other is 2TB.

Any help would be appreciated.
Audacity_error.txt (35.5 KB)

Did you upgrade for a specific reason? We have been highly unwilling to go much beyond Snow Leopard at work because significant changes to the OS have messed up some of our business systems and it will require recoding. Of course nobody has anything better to do. We have been recommending our more aggressive users to avoid the upgrade(s) as well.

So something didn’t change between all the upgrades. How do you have your drives organized? Multiple partitions? Simple drives? FireWire?

What are you doing that could cause Audacity not to be able to “see” all that room? Permissions issues? Have you error checked and repaired permissions recently – or ever? Did you install Audacity as a different user than the one that has access?

Do you have a virus protection system installed?


We know that /User/Koz/Library is a hidden folder now and it didn’t used to be. Did you take steps to reveal it? I know it’s possible because many systems fail with that one change and a work-around was generated immediately. I also don’t remember if that happened with Lion or Mountain Lion. Audacity has to put stuff there and that could create problems right away.


Open Finder, Go > Go to Folder and type

~/Library/Application Support/audacity/

Force Quit Audacity if it is running, then paste in the attached, renamed to “audacity.cfg”. It should set your temp directory to a safe default (at the moment it is probably remembering the bad location from 1.3.4 days).

It won’t help if permissions are messed up, but you can try resetting those if the new .cfg file does not help (Go > Utilities > Disk Utilities (or similar) > Verify Disk and Repair Permissions).

Thanks for the crash report. Audacity does crash in Import/ Export Preferences if it “cannot find anywhere to store temp files.”

HOME/Library was hidden from OS X 10.7 Lion onwards.
audacity.txt (23 Bytes)

I am having the same error message (“Audacity could not find a place to store temporary files…”) come up every time I try to open Audacity 2.0 on my MacBook Pro running Lion 10.7.5 with 8gb RAM and 500gb of free space on my hard drive. I tried replacing the config file with the one attached to the message above, but I still get same message. What the heck is going on? Is this an incompatibility with Mac OSX Lion, or something else? How do I get this resolved?

Make sure you have force quit Audacity (if necessary - Command - Option - ESC) before modifying audacity.cfg.

Make sure you have installed Audacity correctly - you could get this problem if you are running it out of the DMG:

  1. Double-click the downloaded .dmg to mount it
  2. Then to install Audacity, copy the “Audacity” folder from the newly mounted .dmg to /Applications or any other location of your choosing.

If you cannot save to a normal temp file path then you may need to Go > Utilities > Disk Utility then do “Verify Disk” and “Repair Permissions”.

You can also force audacity.cfg to use any location for its temp folder thus:

TempDir=/Users/<your user name/audacity_temp/


Thanks Gale, for that excellent reply to my inquiry. The only thing that made it work for me, was your last suggestion about forcing the <audacity.cfg> to use any location for its temp folder. I created a new .cfg file using TextEdit to type in the information you suggested at the bottom of your post, saved it as a .txt file, quit the TextEdit program and then changed the extension to .cfg. I then went to the menu and held down the option key to open the invisible Library folder. I found the old Audacity .cfg file and replaced it with the new one I just created. Then I tried to run Audacity and IT WORKED! :slight_smile: Thanks for the help.

Thanks. I can only assume then there was some problem writing to the normal /var location.


Yep, that is probably true, especially if it has anything to do with my permissions, which have changed since I originally installed Audacity. I recently changed some of my permissions, and had not tried to run Audacity since. When I did try to run it, the error message popped up. Thanks again for providing a solution to that issue.