Audacity can't open [SOLVED]


I’m having problems when I want to open Audacity. I constantly get a error message: “Audacity could not find a place to store temporary files. Please enter an appropriate directory in the preferences dialog.” I can’t even click on the OK button and I have to force quit the program.

I read this thread but it’s not working for me:

Can you tell me exactly what to enter in the audacity.cfg file please ?

My system is:
OS X Yosemite Version 10.10.1
MacBook Pro (13-inch, Early 2011)
2.3 GHz Intel Core i5
16 GB 1333 MHz DDR3
Macintosh HD
Intel HD Graphics 3000 512 MB

One relatively harmless thing you can try is Repair Permissions.

Go (top bar menu) > Utilities > Disk Utilities.

Pick your system drive and Verify Disk, and then later Repair Permissions. If there is an odd permission problem, the Mac will not let Audacity put files where it thinks they should go.


Bear in mind that Audacity does not officially support Yosemite yet, and you didn’t tell us your version of Audacity (see the pink panel at the top of the page).

If you don’t have at least Audacity 2.0.6, get it here: Audacity ® | Download for Mac OS. Be sure to follow Installation: Do NOT run Audacity from the DMG!!!.

Open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Open audacity.cfg, delete all the text then type in:


If audacity.cfg does not exist, create it containing just


at the top.

It it still won’t work, you may have permissions problems in /var/folders/.

You can force audacity.cfg to use any location for its temp folder, for example:

TempDir=/Users/<your user name/audacity_temp/

That will work (Audacity will create the folder if it doesn’t exist) as long as you have permission to write in or create folders there.


I am running the latest Audacity that you can find on the website 2.0.6.

I did the verify disk and repair disk permission and it is still not working.

I deleted the audacity.cfg file and created a new one. When I’m opening the software, it overwrites the audacity.cfg file and it’s saying:

Gale, can you tell me where to write this down please ?
TempDir=/Users/<your user name/audacity_temp/

You can add that directly underneath


Obviously, replace

<your user name>

with your actual name, without the less than and more than sign.

Are you running as guest or with restricted privileges on this computer?


It worked!!! I can now open Audacity!

It was the ‘‘less than and more than sign’’ that was messing me up. I’m a rookie in those things.

Thank you very much Gale and the whole team. You guys are awesome!!