Audacity stopped recording after Win 10 update.

It is a good thing that I run two computers for this project especially for situations such as this…
Here are the screen grabs for the two sets of preferences and desk top images:
This is from the working set up:
HP Audcaity Settings.JPG
And here is from the system that stopped recording.
Audacitry prefs system 2.JPG
All entries for recording device on the computer that is not recording claim “Loopback”.
The working computer does not claim this.
Is there some other setting that establishes Loopback?

The “loopback” is a special feature of WASAPI. It takes the sound card’s output and uses it (loops it back) to the sound card’s input.
WASAPI” is one of the sound systems offered by recent versions of Windows (Vista and later).

“Stereo Mix” is a similar feature available in some sound card drivers. Old SoundBlaster cards called this feature “What U Hear”. It predates WASAPI and is sometimes buggy on modern versions of Windows.

Windows update is notorious for causing audio problems - just try searching forum posts for windows update.

If you are still having problems,

  1. Check that Windows has successfully completed all of the updates and that there are no brand new ones that need to be installed (Start > Settings > Update and Security > Windows Update > Check For Updates)

  2. Go to your PC manufacturer’s website and review their sound driver software downloads. If the most recent driver doesn’t fix your problem, an earlier one may.

Phase 2,
I now have two identical computers.The original one, that has been in use all along, continues to work, the second one has the following error:
audacity-error hp2.PNG
I now have the latest version of audacity on each computers.
The selections in the three pull-down menus are the same for each computer. I did have to enable the stereo-mix in the audio settings on the offending machine but the error did not change.

There may be other settings to check but I don’t know where to find them.
I would appreciate it if someone can tell me where to go.

Try a different project-rate like 44100Hz or 48000Hz then restart Audacity.
(If the project-rate and the device-rate don’t match that can produce the “invalid device” error).

On the working machine, it is set to 8000. I tried that setting, and all the rest, none of them changed anything.

Apparently Audacity is touchy like that. I somehow got it working on my computer but could never get it working for anyone else.

Are you trying to record something? If so, what?

I am recording broadcasts/podcasts from the internet for single use replay.

Set the Project Rate (lower left corner of the main Audacity window) to 44100.
In the Device Toolbar:
host: WASAPI
Recording: Speakers loopback
Playback: Speakers

host: WASAPI
Recording: Speakers loopback
Playback: Speakers

Ok, but how do I set these? Aside from Host, they are not options in my pull down menus.
Is it something in the Win10 audio setup?

Post your “Audio device info” so that I can see what options your computer has.
(“Help menu > Diagnostics > Audio device info”, then click the “Save” button)

Sorry for the delay, I am a natural born crastinator and have become very good at it.
The attached file from HP2 is what I found. I hope it makes more sense to you than it does for me.

I new twist is that after the latest windows “update” the settings for the working computer (HP1) had to be changed. That one is now working with : Windows Direct Sound, Primary Sound Capture device, and Speaker/headphone/Realtek High Definition Audio.

What caused the change I don’t know. I guessed around until it worked. (-:
I have not been so lucky with the second computer (HP2).
HP1 deviceinfo.txt (4.49 KB)
HP2 deviceinfo.txt (5.16 KB)

Your device settings for HP2 look correct for recording sounds that are playing on your computer, but the device is set to work with a sample rate of 48000 Hz only. The default sample rate for Audacity is 44100 Hz, so that may be the problem.

Have a look in the Windows Sound control panel and see if it is possible to set the Realtek device to 44100 Hz in both the Recording AND Playback tabs.