Audacity shutdown with export dialog.

Hi all,

I do not know whether this is already known issue.
I found the recent Audacity (2.2.1) was shut-downed when I tried to “export” audio as wav.
The file dialog window came on but after that “bug report” related dialog box appeared and Audacity was shut-downed.
This thing happened every time I tried to export.

MacOS version: 10.13.2


I can’t replicate this with 2.2.1 (or 2.2.2-alpha) on my Macbook Pro running High Sierra 10.13.1


And I just upgraded 10.13.2 High Sierra - and I still cannot replicate this (not with 2.2.1 nor with 2.2.2 alpha)


I have attached “debug report” files.
They generated: Reboot system → Start Audacity → Generate 30s silence within Audacity → Try to export to WAV

Thanks (7.07 KB)

Are you sure that you were exporting as WAV?
The reason that I ask is that the audacity.cfg file looks very “clean”, like a “first use, done nothing yet” config file, but there is an export setting for exporting as AIFF.


Perhaps that’s normal for a Mac, but it looks wrong. I’ll need to check on a Mac.


I used file → export → export to wav in menu.
But each time I clicked on it, Audacity stopped working (no response) and the “debug” dialog box appeared.
I do not know why AIFF thing is written on the log.

One thing I should comment: Not just export to wav, I also tried export to mp3 but the same thing happened.


How did you install Audacity? From the DMG or from the ZIP download?

dmg install

Did you previously have another version installed? If so, do you know (or can you guess) which version?
Did you trash the old version before installing the new version?

I have used audacity from 1.x version. But audacity is not my everyday app, I cannot confirm which version is the last one without problem.
I can say 2.1.x had no problem but I do not know whether 2.2.0 worked well or not. (I had installed it but I did not used it.)

In common case, I just overwrite audacity to my Application folder.
For this 2.2.1, at first I overwrote it and there was this issue.
So, I deleted audacity from Application folder, empty trash and reinstalled it with dmg file.

Although I do not think this can be possible cause: I use Homebrew and python, qt and other gnu related files are installed with Homebrew. Could this cause this issue?


That shouldn’t be a problem provided that Audacity was installed from the official Audacity DMG (, but could be related if Audacity was installed with Homebrew.

Am I correct in thinking that you did not use Homebrew for Audacity?

I’d like to clarify the question of the curious “ExportFormat_SF1=131074”.
Could you try the following:

  1. Trash Audacity and the folder “~/Library/Application Support/audacity
    (note that “~/” refers to your Home directory. It is NOT the system Library.

  2. Get a fresh download of Audacity 2.2.1 from here:
    Audacity 2.2.1 .dmg file (31.13 MB, includes help files)
    and check that the SHA256 is:
    (this is possibly overkill, but it ensures that there are no problems with the downloaded file, and in weird cases like this it is good to rule out possible causes)
    An easy way to get the SHA256 is to use this web-page:

  3. Follow the instruction for installing that are given on this page:
    Be sure to follow the instructions to the letter - read through the instructions before you start.
    (I’m stressing “to the letter” because again we need to rule out possible causes).

  4. When installed. Launch Audacity. Take note and tell us of any errors / warnings that occur.
    Do not do anything in Audacity other than dismiss the “Welcome” screen. Just let Audacity fully open, then close it again.
    This is to ensure that Audacity completes its initial “Preferences” setup.
    Ensure that you fully “Quit” Audacity (I’m aware that macOS loves to keep applications hidden in the background).

  5. Launch Audacity again.

  6. Import a known good WAV file (ensure that it is a normal 16-bit WAV file). Accept the default options when prompted.
    Allow the file to fully import.

  7. Export as WAV using “File menu > Export > Export as WAV”.

I’m guessing that at step 7, Audacity will crash. If it does, please send the new “debug report”.

Of course I do not use Homebrew to compile or install Audacity.

Here are new debug report files from above steps. (7.24 KB)

Thanks. That has provided a complete audacity.cfg, but there it is again:


I’ll need to check that out on a Mac to see what’s happening, because it looks wrong.

I found this issue happens not only with “export as…” menu but all menus related with file dialog.
Mostly, I import wav file by drag and drop the wav file from finder.
Today, I tired to import wav with File → Import → Audio the same thing happened again.
Then, I click menu File → Open… and the same shutdown happened, too.

FYI, other menus which open dialog/window not related with file dialog do not show this.

It seems like this thing closely related with the file dialog. But I do not find any similar things in other app (text editor, Keynote…etc)


I found there is other application, XLD, shows the same issue (crashes with file dialog)
It seems like this issue is not related with Audacity directly but my Mac system itself has some problem.
I do not know what is the common point with Audacity and XLD and (not other apps such as Apple’s Keynote or MS’s VS code…)
What I only know is XLD and Audacity are music file related application.

This is do not disappear after I reinstall MacOS (not clean reinstall but just overwrite.)

One other thing I found is when I login to Guest account, Audacity and XLD work find with the account.

Is there anyone knows about this??

Hi All,

I found this issue was fixed (or disappeared) after I upgrade OS to 10.13.4, recently.
I did not do anything with Audacity (just installed and tested new versions but always failed.).
However, with recent MacOS, Audacity works normally.
I do not know what happened, anyway it is good it was fixed…

FYI, XLD had the sample issue with the previous OS but it also works well with current OS version.


Thanks for the update. Glad it’s now working.