Audacity Project Recovery causes error msg: database disk image is malformed

Command “audacity-project-tools -drop_autosave broken.aup3” causes
the error message “database disk image is malformed”.
This seems to somehow correlate with regular error messages in
Audacity itself, like

“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “SqliteSampleBlock::GetBlob::step”

What could be the reason for this behaviour?
Thanks in advance, Bernd

So this likely indicates that the .aup3 project database file is beyond recovery. However, if you wish to zip it up and upload it somewhere, I’ll take a look at it. Post a link.

thx a lot for your support! I’d like to send you a link but I would prefer a private message. unfortunately I am not yet allowed to use this function in the forum.
besides I found out that the errors occur with every .aup3, sooner or later

Perhaps you are cutting and pasting tracks from a damaged project…

I am not sure, but I think you can send me a DM here: Audacity.

Note: I normally ignore PM/DM’s; however I’ll be on the lookout for yours.

detailed problem description:
“timestamp”: 1675077022,
“event_id”: “87a868ff8303c241b3975ddb5f38dc4a”,
“platform”: “native”,
“release”: “audacity@3.2.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.22621”
“exception”: {
“values”: [
“type”: “Error_Saving_Project”,
“value”: “Audacity failed to write to a file.\nPerhaps is not writable or the disk is full.\nFor tips on freeing up space, click the help button.”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “ProjectGileIO::”,
“log”: “\tLibraryError: database disk image is malformed\n12:10:22: sqlite3 message: (11) database corruption at line 69959 of [1b256d97b5]\n12:10:22: sqlite3 message: (11) statement aborts at 15: [INSERT INTO SELECT * FROM WHERE blockid = ?;] database disk image is malformed\n12:10:22: DBConnection SetDBError\n\tErrorCode: 11\n\tLastError: Failed to update the project file.\nThe following command failed:\n\nATTACH DATABASE ‘’ AS outbound;\n\tLibraryError: database disk image is malformed\n”

I sent you a recovered zip file. Hope this fixes the problem.

Oh - and avoid working on networked drives…

with the file you restored, there are no more error messages so far. if you managed to do that with the audacity project tools, i would like to know what i did wrong… :wink:

thanks a lot for your support!

Yeppers, just followed my directions in the first post here: Corrupt or Otherwise Broken Audacity Project Recovery

Hi, is there any chance I can send my aup3 file to you? I have tried repeatedly to repair the file but it remains broken, if possible it would be good to know if it is beyond repair or not. I tried -extract_clips as well and I got the ‘database disk image is malformed’ response so I’m not hopeful.

Also if you have any advice on how to avoid getting the “Audacity failed to read a file in C:” (or D:, E:, …) error message I’d appreciate the information as I’ve had to do this recovery process multiple times in my past few projects and it’s worrying to say the least that I may have lost this one.

Well, I am honored that you asked, but I stopped doing this - I am only a lowly volunteer and I have personal objectives. I imagine you could post a link and someone might take a look at it for their own edification.

Your particular issue has nothing to do with being able to read a file; this is simply the erroneous manifestation of an underlying corrupt database (.aup3 project). The database itself is pretty robust, but device or timing errors can lead to difficulties. People who hold their database completely local to their machine seem to have better results. Wifi and particularly remotely located databases or backup services may contribute to these errors.

I’ll be honest I don’t really understand some of that. My Audacity application files are stored on my D drive but I save to my E drive if that’s worth anything, both are internal and wired respectively. Is this causing an issue as far as I should save my projects on to the same drive the application is operating on? Again I may be misinterpreting what you’ve said.

That’s fine, I’ll try and find a workaround as I’m unable to re-record the audio as it was. Thanks for replying so fast and offering help!