Audacity not showing in microphone privacy settings

I have recently updated OS to Catalina 10.15.3 and unable to record through audacity. I have read the other posts on going through terminal which should then over ride but it is still not working, it is just a flat line record, have also tried going through soundflower and updated input settings on mac/audacity to soundflower (2ch).

Audacity also doesnt seem to be showing in the privacy settings even after going through terminal (shown below), could this be the problem, how do I enable this to show in the privacy settings?

Assistant would be greatly appreciated.


Screenshot 2020-02-09 at 14.52.18.jpg

See this sticky thread:


Thanks, as mentioned I have tried this and still not working, the issue seems to be audacity not showing in privacy settings?

Using this workaround does not grant access to Audacity - rather it grants access to Terminal (which passes permissions through to Audacity) so I would not expect to see Audacity in that list.

When I enter the command in terminal it opens up audacity but doesnt ask for permissions, shown below. Any ideas?
Screenshot 2020-02-09 at 15.12.28.jpg

Microphone seems to now be working, but now seems to be extremely high pitched and distorted sound as picking up all types of background noise, how do i avoid this please?