Audacity not recognizing PreSonus Firestudio on new MBP.

Hi there. Hoping to troubleshoot a device recognition problem I’m having since upgrading to a new MacBook Pro.


Audacity 2.3.0
OSX Mojave 10.14.2

PreSonus Firestudio Mobile
AT4040 microphone

I had previously been running this firestudio set up for mono track VO recordings (auditions, audiobook narration) on my old MBP. Since upgrading to a 2018 MBP I can’t seem to get Audacity to recognize my interface/mic configuration.

I AM getting an audio signal through the mic, and I’m hearing it through the headphones (both connected through the powered interface (FireStudio Mobile). What audacity is recording, however, is the default computer mic. The PreSonus is not showing up as a device in the dropdown, and I have rescanned for devices.

Perhaps I’m missing some drivers on the PreSonus side that I no longer recall having installed on the old MBP?

Also curious if my trouble is connected to the daisy chain between the MBP and the interface. I have an Apple Thunderbolt 3 > Thunderbolt 2 > Firewire adapter chain set up (as recommended on the PreSonus site). Again, I am hearing the audio through the mic set up, but it isn’t recognized within Audacity (nor in Apple’s system preferences).

Any help would be appreciated. Thanks!

Where are you seeing that?

That should probably happen, independent of whether sound is getting to the computer, so that only tells us that your mic and headphones work, but not much more.

Do you see the meter respond to your voice in the “Sound Preferences”?

Have you given Audacity permission to use the microphone? (See: No signal from USB turntable (Mojave) [SOLVED] - #6 by SonArc)

Thank you Steve.

The signal I’m getting though the mic is not something I’m registering visually, only hearing through the mic and headphones.

I do get a meter response through Sound Preferences, though I’m only seeing the built in mic so I assume that’s where the reading is coming from.

I have given Audacity permission to the mic, but that seems only to give it permission to the built in.

Look in “System Preferences > Sound”, and select the “Input” tab.
Is the PreSonus Firestudio listed? If it is, select it and see if speaking into the microphone causes the meter to respond.

I’m away from my setup at the moment but I do recall checking this before in system preferences and, no, only the internal mic was listed in system preferences > sound > input. Though I will double check this after the weekend.

Hi Steve-

I wanted to provide an update as it looks like my situation is resolved.

One of the stipulations on using the FireStudio Mobile with a new Thunderbolt port was that the interface would need to be externally powered (no longer relying only on the firewire cable to the computer for power). While I was aware of this, and had plugged in my interface via the supplied power cord, I was getting intermittent power, hearing a sort of ‘click’ repeated and the light indicators sometimes flashing and sometimes holding steady.

I ordered a new power cable as a last ditch attempt and it worked. All systems are go. Seems I had a faulty power cord. I can now recognize the PreSonus in the Audacity dropdown and recording is working fine.

Thanks for the input.