Audacity locks up when trying to save

There may be an answer for this already, if so you can move or delete this as necessary.

Windows 10
Audacity (2.2?) upgraded to 3.0

This started a couple of days ago when I was using 2.2 or some version like that. I’d recorded about 6 hours of music and had finished another. When I went to save the whole screen simply froze, locked-up, trying to save as mp3. Could not execute any commands at all. Screen completely frozen. Shut down, start up, Audacity asked if I wanted to save file, I said yes and it locked up again. And again. (I’ve done hundreds of hours of recording this way over the last 4 years with no problem at all)

One suggestion I read here was to clear cache, which I do pretty regularly but I did it again and it did fine with a 3 minute song after that so…problem fixed, right?

Did another 6 hours or so of recording yesterday, no problem, then I recorded a 30 minute symphony and…same problem again. Cleared cache again, restart, do you want to save old project?, Yes. locked up again. Same, same thing.

Audacity webpage said there was a new version as I was reading the forum for help so I downloaded the 3.0 which worked fine for about 2 hours today. Changed CD’s and I’m back to lockup trying to save a 4 minute song. The new version seems to do fine with the recording part, and as I say worked fine for 2 hours, but a CD change seems to have messed up everything again.

Shut down, started over, it tells me there is an unsaved program, do I want to save?, yes, I get to the right folder I want to save in and it locks up again.

I think I was able to reset the settings to my preferences on 3.0 and it did work in the morning. There may be a simple solution but I can’t figure it out and- I still can’t figure out why this problem started. Everything is saved as mp3 on a 256 gig flash drive so plenty of room there.

The external storage may not be what’s holding everything up. How much internal storage do you have and do you use Cloud Drives?

When was the last time you defragmented the internal drive? If it’s a Solid State Drive, defragmenting is a bad idea but checking the quality of the internal drive is a terrific idea.

The shows are bigger than you think. The uncompressed size of 6 hours is about 4GB and internally, Audacity keeps even larger versions for edit quality. Every time you do some edits, Audacity tries to save the whole show as UNDO.

This is the sticker shock when people try to do production with MP3 files and are stunned how big the sound data actually is.

What else do you have running and when was the last time you restarted the machine? Do you still have those problems with the network disconnected?


Hi Koz, thank you.

So I think, in order,

  1. AT the moment, is says 92.9 g of 231 g available on C drive. I have some large video files I need to move but Audacity has been working fine even with those.
  2. It’s a solid state drive.
  3. I’ve recorded 2.5 or 3 hour operas with no problem so I can’t figure out why a 4 minute song won’t save.
  4. Last night trying to save the 30 minute symphony I finally had only the folder on the external drive and audacity open (with whatever MS things that run in the background).

Also, I’ve run C Cleaner again to see if there’s more to clear off but there isn’t that much since I’ve run it 2-3 times to see about saving space on the hard drive.

Omg, I tried it on my other computer (solid state drive, Windows 10, version 2.2.2) and it just did the same thing. It worked for about 45 minutes then locked up and won’t save the current project.


There are two known problem in Audacity 3.0.0 on Japanese Windows.
The problem that you describe sounds like it is this issue: which is a bug in Windows. We are hoping that Microsoft fix this soon.

The other one is this issue: which we believe has been fixed in the development code. The fix will be available in Audacity 3.0.1 which is due to be released later this month.

Thank you steve and Kuropon.

Except, as I say, it even happened on my other machine which had 2.2.2. :confused:

Please take a look at this link and see any of these Microsoft workarounds help:

And…almost as soon as I ask, it’s working normal now and I haven’t changed anything although I have run cCleaner about 3 times a day. So thank you everyone for the suggestions. I will keep this in mind if I run across the problem again.

Well, it’s doing it again, on both computers. The newer version worked fine for one day then on the fritz, the older version worked for 2 days and now on the fritz. So I have to calm down and think what to do next.

Perhaps best to go back to Audacity 2.4.2 for now. You can get it here:

Audacity 3.0.1 is due to be released very soon. Worth trying that as soon as it becomes available.

3.0.2 doesn’t work any better than the earlier versions.

There were some new diagnostic error messages introduced in 3.0.2. Are you getting any of them, or is your machine just locking up with no indication?

Problems with Audacity locking up after upgrading from Audacity 2.4.2 to Audacity 3.0 & 3.0.1:

  1. Editing and saving commands take an extremely long time to fully execute. Using previous versions to execute those functions was reasonably quick and much less time consuming. I expected the larger file sizes in 3.O to increase executing times, but the resulting time lag is making the recording and editing process take so long it’s almost un-manageble. Saving and editing has now slowed down to a crawl.

  2. After taking great pains to save and close files in the proper sequence, I continue receiving messages indicating that I failed to close the file properly. Selecting the option to recover the indicated file, does not present me with the obvious location of a recovered file. What appears is my usual listing of what I’ve assumed to be my undamaged files. It would be helpful and reassuring to receive a message or response indicating that my working files are still complete and undamaged or a flag indicating the newly recovered file.

My computer Features: ( Intel(R) Core™ i9-10900 CPU @ 2.80GHz 2.81 GHz, 64-bit operating system, x64-based processor, 16.0 GB (15.7 GB usable), Windows 10 Pro OS. I have 1 1/2 Terabyte of free hard drive space. This system has worked flawlessly with previous versions of Audacity. The above mentioned problems began after updating to the 3.0 release and are still present using the 3.0.1 release, which I downloaded and attempted to use this evening. Every other program I run on my computer executes as fast as before. I find it hard to believe that the problems I’ve listed above are not showing up among a large number of current Audacity 3.0 & 3.0.1 Windows users. If that is the case, I would greatly appreciate any suggested work arounds that would allow me to continue using what I’ve considered (up to now) to be awesome program? Thanks

There was never a 3.0.1 - we went straight to 3.0.2 from 3.0.0

I did a lot (and I do mean a LOT) of QA speed testing of the new Unitary Project 3.x throughout the alpha development and the Release Candidate stages.

This was done on Windows 10 PC and Macbook Pro under 11.2.x Big Sur with hour long stereo projects. My measured results showed us the in general most things were roughly the same in time taken, but some of the effects were quicker in 3.x. We would not have releases 3.0.0 if it had exhibited the sort of serious slowdowns that you are reporting.

The one thing that we know takes longer is exiting from Audacity - and that is because Audacity has to clean up the project database on exit and release the unused temporary space it was holding. If it did not do that your projects would quickly become huge.

I’ve also been using the alphas and RCs for my weekly production work where I capture a 2-3 hour show from a Webcast and then edit it an output to MP3 for later use. I have not found that processing to be made slower by using 3.x

So I am more than somewhat puzzled by your report here …


There were a couple of issues found in 3.0.0 shortly after release which none of the QA testers had found - and indeed even after they were reported by users they proved impossible to provoke on demand and thus very hard to diagnose…

One of those was a false recovery (which sounds like what you are reporting here) - this caused no damage, one could either discard the offered recovery if one new for certain there had not been a crash to cause a recovery - or you could accept it and it would “recover” an empty project.

We think that this may occur when you exit Audacity without saving the project and then relaunch later - but we can’t repeat this in tests.

We have made some database changes for 3.0.2 but at thus stage we don’t know if we have fixed this (because as I said above we can’t provoke this when testing). One of the changes is to add some more diagnostic information to the error message - so if you get this again and are offered a diagnostic log please do generate that and post us a copy here on the Forum.


Both my machines are pretty similar in Spec (yours is higher spec):
Both are 2-7GhZ 8GB RAM dual-core
Both have 256GB SSD ( Win has 60GB free, Mac has 90GB free)
Both are Intel processors - Win is i7 Mac is i5
I’m using windows 10 Home on the PC

Yes I’m using SSD - but my PC also has an onboard 1TB spinning metal disk - I recently did timing tests of SSD versus HD and was surprised to find very little difference between the two.


No. Same thing. Record, save as mp3, the save box pops up then locks up. Still can’t name and save.

So, I am at a loss. I don’t believe any of your files are network drives - if they are, that could be the cause of the problem. Also, there was a Windows update earlier this week - you can see if this helps anything. And I believe you said this happens with 2.x Audacity as well as 3.x, so changing versions doesn’t seem to help you.

I believe Kuropon was thinking that Audacity or Windows was somehow choking on the file name - I have seen this happen before. Have you tried first saving the project, and then recording in to it?

I did as Steve suggested above and went back to 2.4.2. It works just fine for the last 3 days. Just like it always did.