Audacity Keeps Crashing - Catalina

I’m a relatively new user to audacity, but I haven’t had any issues for the past few weeks (even after I upgraded to Catalina, no issues). Suddenly, today Audacity keeps crashing as soon as I open up the file I’m working on. It freezes and won’t even let me submit the bug report, and I end up having to force quit.

Any idea?
Screen Shot 2019-11-11 at 9.32.38 PM.jpg

Does the problem occur only with that one file?
Is it actually an “audio file” or are you opening an “Audacity project”?

“Suddenly, For No Reason,” problems can mean you ran out of something. The video people get this, usually in the middle of a big show.

When you get the machine back, Apple (upper left) > Shutdown… > Shutdown. Wait for it to clean up the broken bits and the spinning daisy to go away. Start. It’s agood idea to do this any time you have a catastrophic failure like an app crash. Those can leave trash lying around and cause instability.

Go (top of desktop) > Computer. Right+Click or Control+Click or Control+Tap Macintoch HD > Get INFO.

What is the Capacity and Available?

How large/long are the shows?


It was an Audacity project. I started a new project to see if I could identify the problem. I’m dealing with three files: (1). the raw audio recording (.m4a), (2). The intro recording file (created with Audacity, .mp3), and (3). The outro recording file (created with Audacity, .mp3). I started with just the raw audio (.m4a), edited it a bit, did noise reduction, cut some things, etc. No issues.

Then I added the intro file, and tried to move it to where I wanted it and it crashed (see attached screenshot). So maybe it’s an issue with that file for some reason?

See attached screenshots. Plenty of space available.

The main audio file (.m4a) is 6.7MB. The intro file (.mp3) is 703KB, and the outdo file (.mp3) is 1.1MB.

I’ve had the exact same issues (in macOS Mojave) since updating Audacity to 2.3.1. It crashes almost every time I cut and paste audio from one project or track to another. Like the OP, I can’t even click ‘ok’ or ‘cancel’ on the error message - I can only force quit and restart. Thankfully I can usually recover my work, but I hit another crash within a short while.

I updated to 2.3.2 in hopes that it was something that had since been resolved, but it keeps happening.

I have plenty of HD space available (> 100 GB), plenty of RAM (16 GB), and plenty of processing power (3.1 GHz Intel Core i7).

I never had a single crash for years of weekly use of older versions, so I’m going to downgrade to 2.1.0 and hope that helps.

As this thread is about Catalina, your issue is not “the exact same”. Please start a new topic if you require help with your issue.

I cannot reproduce this on my Macbook Pro running Catalina 10.15.1 - I tested with both 2.3.2 and the latest Release Candidate I have for the upcoming 2.3.3


My apologies for not being more specific. I was referring to the “Audacity Keeps Crashing” part, but because OP doesn’t specify which version of Audacity he or she is using there is no way for me to know if I have the exact same issue.

I should have written "I’ve had the same error messages and crash phenotype,” removed the parentheses, mentioned that I have encountered the issue using macOS Catalina too, explained that I think my underlying issue isn’t a matter of Catalina vs. Mojave in the first place, or started a new thread.

Poor word choice notwithstanding, after further testing, I have determined that Audacity v2.2.x does not suffer from this problem, so I have downgraded and consider my issue solved. Thanks.

[The quickest method I’ve developed for triggering repeated crashes of v2.3.x is to open a handful of FLAC files in different projects, select all of one track, cut and paste it into another project, and repeat (cutting and pasting tracks between projects) until you see the crash and have to force quit. It typically takes me ~3 cut-and-pastes between projects to reproduce the error in Audacity v2.3.1 and v2.3.2 in macOS 10.14 and 10.15.]

I also made the mistake to upgrade to Catalina. This is what happens to me: As long as I am working on two mono tracks (podcast audio recordings), the system is stable. As soon as I copy a stereo track (e.g. music) into the project, it starts crashing. I even lost the entire work of three hours yesterday. So I cannot finish my projects on my MacBook anymore until this problem is solved. Fortunately, I have an iMac at home which still has an older operating system. But I am frequently travelling so I am pretty dependent in my MacBook. Any hints on when the next version of Audacity for Mac will be released which solves this problem?

We are hoping that the next Audacity release will be fully supported by Catalina. Unfortunately we will probably not know for sure until it is released, because we will not be able to test the “Apple notarization” until the notarization has been approved by Apple, which as I understand it, cannot happen until the release version is ready for public release.