"Audacity is already running" error. [Solved]

I’m getting the “audacity is already running error” and I’ve tried all the fixes I’ve found online. Reinstalled, restarted my mac and tried to delete temporary files ghosting around. Is there something I’m missing?
I run MacOSX High sierra.

What version of Audacity?
– Bill

I have the same problem. I recently updated to High Sierra 10.13.6
Now it is impossible to use Audacity 2.2.2 or 2.2.1
I have removed, redownloaded, etc Always says that another instance of Audacity is operating.

I’ve used Audacity for many years and have never had such a problem

Reboot the computer (without reopening current windows), then look in:

~/Library/Application Support/Audacity/Session Data

where “~/” is your home folder.

Find the file:


and delete it.

You should now be able to start Audacity.

When shutting down the computer, ensure that Audacity is completely closed before you shut down (by default, macOS keeps applications running in the background even when all of the applications windows have been closed).

I got the same error message last but cannot do the recommended fix protocol for the following reason:
I am on MAC OS 10.14.6 and there is no ‘Go’ within the Finder menu. My only options are About Finder, Preferences, Services, Hide Finder & Hide Others. I tried doing a Command F and typing in ~/Library/Application Support/Audacity/Session Data which I think was your recommendation, but nothing happened. Please help as I am completely stuck in my project and need to get it posted this weekend.

Does your desktop look like this?

Screen Shot 2019-09-20 at 10.27.04.png
That’s the “Go.” Followed by Go To Folder.

Screen Shot 2019-09-20 at 10.29.43.png

Yes, sorry, thought the Go had to be under Finder. Yes you can laugh at me. But I still can’t fix it. I went under Go, then Go To Folder, then pasted in ~/Library/Application Support/Audacity/Session Data

What am I doing wrong now?

Just for grins and giggles, did you shut down your machine? I don’t mean Restart, I mean Apple > Shut Down…

Wait for everything to clear out and lose the little spinning daisy. Wait a bit and then Start [CHONG]. I know I’m going to get in trouble with that. The super new machines don’t Chong any more [sigh].

I do it one step short.

~/Library/Application Support/audacity
Please note the Audacity is lower case, not capitalized. Do not leave out that squiggly line character (Tilde) at the front.

Screen Shot 2019-09-20 at 18.41.47.png
That sends you to here which is a set of Audacity tools and folders.

Screen Shot 2019-09-20 at 18.42.32.png
Double click SessionData to open it and it should look like this on a normal machine without Audacity running.

Screen Shot 2019-09-20 at 18.42.46.png
If I launch Audacity and then do that search, I get a lock file that looks like this.

Screen Shot 2019-09-20 at 18.54.30.png
If you have a lock file but no Audacity, delete it.

I would kill to be able to say you can search for that file with the magnifier glass Spotlight tool in the upper right, but it seems they didn’t want us poking around in the heavy system files so it fails. !@#$%

Where did you lose it?


That worked! Thank you so very much.