Audacity Freezing


Thank you in advance for your help. This is the first time I am experiencing this issue.

Audacity is freezing at random times while running, though it is sometimes triggered by input. This input can be a click of a button (Play/Record, etc). It has even frozen when I pushed a keyboard letter during opening a file to quickly find that filename in queue (i.e. I pushed the letter G to find a file that started with the letter G). The freezing often happens mid-recording or playback as well. When it freezes the program keeps running (recording doesn’t stop), but it completely ignores any user interaction (Buttons don’t acknowledge mouse hovering, etc.). I don’t believe it has frozen before I’ve started operating a file. It occurs no matter what file I run, whether a saved or new one. There have been a few rare occasions where, after several force-closures of the app, it will run without freezing. Of course, the problem also doesn’t go away no matter how long I wait.

I have tried several versions of Audacity, installed a fresh FFMpeg library, updated all my audio drivers (tried a couple of different ones via Realtek and manufacturer), and even bought a new mic to eliminate the possibility of a bad cable, etc.

I am running Windows 10 on an AORUS B550M motherboard. 16GB RAM. AMD 5 3500. (System file and Audacity Log file included).

Thank you for your help!

Audacity Screenshot.png
log.txt (2.02 KB)

I see you are using an English display, however, is it possible you are using an oriental version of Windows? See: Freezes when keying in Japanese

Things like this seem random, but something is causing this behaviour. It’s a matter of going through things methodically.

I’m left with the impression that you are far from technophobic.

First, try and replicate the problem - open task manager and click OPTIONS / check ALWAYS ON TOP and keep it floating to one side on top of Audacity.

The game plan being to see if anything is preventing Audacity from doing its job by eating up resources, i.e. CPU cycles, memory.

Be prepared for a waiting game. Every time you run Audacity open task manager as well.

If Audacity plays up, go to task manager click on PROCESSES tab, click on the CPU column so that sort arrow is pointing downward.

Have a look at the top of the list to see which program is CPU hungry.

My own experience is:

  1. Internet browser
  2. Windows antivirus / malware doing a system wide check (usually at the most inopportune moment).

While Audacity is being tied-up (I don’t think it’s the program at fault - been using it for too many years) try this.

  1. Closing down the browser and disconnect from the internet.
  2. Try to clear the taskbar of as many programs as you can, and see if it helps.
    Do this before you start Audacity.

Try a re-boot (no just signing out)

Start Audacity.

If it is working fine - then back-up the C:\Users**user account name\AppData\Roaming\audacity**

Right click in the window - select new ZIP folder - name it - highlight & drag & drop files into zip folder.
Note: PLUG IN FOLDER is usually empty and will not be included in the zip. Check and you’ll see they are all backed-up. This is good housekeeping.

If Audacity plays-up next time. Open the zip folder in a new window and drag and drop files into C:\Users**user account name\AppData\Roaming\audacity**. This will overwrite any corrupted files.

Restart Audacity.

If none of the above work, get to me on this forum.

Thank you both for your replies! :slight_smile:

I never would have suspected that! Very keen of you consider that, as I DO use Microsoft IME for two language inputs. The link you included leads to Microsoft files that apparently “aren’t applicable to my system”, however. I’m not sure if it’s because they’re older than what currently is installed or for another reason, but I did follow the advice on there to roll-back to an older IME version - which may have fixed the problem temporarily: the freeze has not duplicated since.

Thanks for taking the time to really help me out with this! It’s shut-down my whole audio editing, basically. :cry:

I did like you said and monitored my activity for quite some time, though since rolling-back the IME version for now, the freezing appears to have stopped. Though I tried a couple of other solutions as well after the time of this post, I am thinking it is indeed an IME conflict (like you said, there must be a trigger somewhere), which seems to make sense when even a keystroke would trigger the freeze. I am not sure how long this temporary solution will work, though…

Thanks for the report back. I am glad to see that you are back to working (at least for now…) :wink: