Audacity failed to read from a file in D:

Windows 10 Home, Audacity 3.1.3

Hey all,

Been messing around with an audio file for a personal project of mine and effectively messed it up to the point where I get the dreaded “Audacity failed to read from a file in” error, and I’ve exhausted every solution I could do on my own at this point. Basically I started messing with the file, normalizing and undoing some things, then decided I would deal with it later. Didn’t want to save it and didn’t think it would be a problem, so I exited out of the file, clicked cancel on the “compacting project” prompt, and I’m pretty sure it had a prompt that was something to do with the undo history that I clicked out of as well. Instantly realizing that I probably messed something up, I tried to open the project again and was unable to, with the dreaded error and the provided information below.

“timestamp”: 1641780295,
“event_id”: “b7a74be3b9979c4e8516fada8f5334d4”,
“platform”: “native”,
“release”: “audacity@3.1.3”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19043”
“exception”: {
“values”: [
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “101”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”

I am the ultimate cause of my own downfall :open_mouth: If anyone has any other tips to try or can offer direct help, please let me know!

Where is D:?

Good answers to that are a second internal drive in the computer or two partitions or segments on one internal drive. All the rest of the possibilities are not so good. Audacity doesn’t much like external drives, thumb drives, network drives, or cloud drives.


So if you care to zip up your .aup3 file and upload it to a public file sharing service, then post ( or PM me ) a link, I’ll take a look at it.

D: is my second internal drive, I did also move the file to the C: drive to see if it would work there and nothing.

thanks jademan, I’m uploading the file to dropbox but my upload speeds are painfully slow, hopefully I’ll be able to post the link tonight

here is the link to the file! forgot to zip it so it took way longer than it should have :unamused:

So I took a look at your project file. The first pass was not fruitful. I have other tricks up my sleeve. I’ll keep you posted. As you know, it is a big file. :wink:

OK, the second pass is more fruitful. :smiley: I’m putting together a recovered file for you, but it won’t be ready until tomorrow. :frowning:

Wow! Thank you so much! You’re the absolute best!

:blush: (blush!) :blush:

I have PM’d you the link to a recovered file.

Ah! Thanks! I had really expected it to be gone forever :smiley:

You are welcome. :smiley:

Hi, I’m having the same issue. Can you tell me what you did to recover the file?

I noticed this morning after getting the error late last night that my temp files directory somehow got moved to a different directory from my main save location (external hard drive, which I will only be using as backup from here on out). I tried looking for my SessioinData in the folder that was listed to try and move it to where the .aup was saved, but it says the folder is empty. Is there a way to find where that data ended up? Or a way to get my .aup file to open anywhere?

It depends on what version of Audacity you have. There are some tools that I and others have developed that work for .aup3 3.x.x project files. They do not work at all on 2.x.x .aup files and related _data files.

I am the wrong person to help with .aup 2.x.x project and related _data files.

What version of Audacity have you been running?

I just downloaded about a week ago, I believe the version is 3.1.3.

In that case, you should have .aup3 project files, NOT .aup files.

So, zip up your .aup3 project file and upload it to a public file sharing service. Post (or PM me) a link; I’ll take a look at it.

Hello again,

I am so sorry for the delay, it took an absolute eternity to upload this. here is the link, please let me know if you have any trouble accessing it.

Thank you so much for this help!!

Zipping and uploading your recovered project now. - As you know, this will take a while… :wink:

You are welcome. I have PM’d you a link to the recovered file. :smiley:

oh my gosh thank you so much I can’t tell you how much this means to me!!

You are welcome! :smiley: