Audacity failed to read from a file in C


I’m having some issues exporting my file to .WAV (or any of the other export options). I didn’t have any issues exporting the first time I exported a file but this second time, a window keeps popping up with “Audacity failed to read from a file in C”. I have been checking these boards for any information (i.e. making sure I’m saving in the right file, making sure I’m not only selecting part of the file to export, making sure to stop the recording and not just pausing, etc). I also made sure I didn’t have any strange characters while saving and made sure I had enough space on my computer. I’m definitely at a loss and would appreciate any help.

I’m using Windows 10 and Audacity 2.2.1

Thank you in advance!!

Audacity used to have an odd problem where the default place to save files was the System portion of the drive. The System didn’t like that much. What happens if you export a file to the desktop? The desktop definitely belongs to you, unless you have multiple users on your machine.


When was the last time you cold started your machine? Shift-Shutdown instead of regular Shutdown or Restart.


I feel like such a dork but thank you!! That worked! I really appreciate it.

That worked!

Which one?


I was able to export the file once I saved it to my desktop. Thank you again!

I have found a solution to “Audicity cac’t read from file C” follow the YouTube Link

Not really a “solution”, but that’s a useful technique for recovering at least most of a recording when some of the data on disk is unreadable.

If the project is working (plays correctly from start to end) in Audacity, then a better workaround is to save the project with “Save As” and save it with a different name. This will make a new copy of the project data, which will hopefully be readable.

Note that this error indicates that the hard drive could have a bad bit, or may be failing, so it is highly recommended to run diagnostic checks on the disk as soon as is practical to do so (and hopefully avoid further data loss).

Or it may be that the disk you are exporting to is full.

I encountered similar today when testing disk-full bugs for the up-coming 3.0.0 Audacity.

I got this “Audacity failed to read from a file in G:” message one time, but only one time, when I was testing exporting to a USB stick that was not big enough for the exported file.

All other times I get the proper intended 3.0.0 message:
Disk-full Red-Zone error.png
One think to note is that for 3.0.0 we are adding a “?” help button which links to a new page in the 3.0.0 Manual giving you advice on how to deal with this and safely salvage your project: