Audacity does not record

Hi there,
I have been using an Roland Edirol UA-1Ex Audio Interface for a long time with Audacity. Although Win 10 is not set up to use the UA-1Ex, a simple tweak makes it work. The UA-1Ex In and Out lights up correctly in the instrument, UA-1Ex, computer, UA-Ex1, mixer, amp, speaker chain. So far, so good.
Audacity settings: Win WASAPI, Speakers (3-UA-1EX (loopback)), 2 stereo recording channel, Speakers (3-UA-1Ex), recording slider up, transport options software playthrough on, Project Rate 48000 Hz.
Windows: Win 10 home Version 1909, OS build 18363.1139, 1/8/2020, 16 GB RAM Lenovo Y50 gaming laptop
Win Sound settings: Output Speakers (3-UA-1EX), Input Stereomix Realtek High Def. Audio (no other choice)
Win Sound shows UA-1Ex in the device list.

problem: Audacity doesn’t record, although cursor is running, only flat line. Input and output go through and I can hear the instrument coming out of the speakers. Good volume. Switching Software Playthrough off causes the cursor to freeze, I have to reboot Audacity to get out.
Trying MME, Win Direct Sound, Stereomix, Loudspeakers options don’t work. Tried Project Rate 44100 Hz. Changed the UA-1Ex input volume, no effect.

I checked the comments and topics, manual and searched online to no avail. What is the problem? Thanks for your input.

WASAPI loopback is for recording audio that is playing on the computer - on your onboard soundcard.

I too have an Edirol UA-1EX (I need to nudge Windows to turn it on as an active device).

I have either
a) my record deck plus preamp
b) my tape deck
c) my FM tuner
connected to it via a SkyTronic multi-way switch.

For host I do not use WASAPI for this, normally MME, though I seem to recall that Windows direct sound works too.
This all works fine for recording.

I do use WASAPI loopback too - but then is when I want to record Internet streams.


So… If that’s what you’re trying to do… record streaming audio… Try your regular Realtek soundcard. Plug your speakers into the Realtek, make sure the sound is coming out of your regular soundcard and then select Realtek (loopback) as your recording device.

If you are trying to record from something plugged into the interface you’ll have to select the Roland and either the mic or line-input as your recording device. (Don’t use the loopback option.)