Audacity crashes constantly on Catalina 10.5.7

Hi I’ve been using Audacity happily for some time now but it has suddenly started crashing. When I reopen it offers to recover the project but always finds errors and the work that I’ve done isn’t saved. When I listen to the file it sounds ok but when I export to mp3 it is garbled. I made sure I had the latest version of Audacity and also the latest version of MaciOS (but realise the latter could be the problem)
Does Audacity support 10.5.7. I read it supported 10.5. If it doesn’t is there any way I can go back to an older iOS version do you know? Thanks Maggie

I’m using Audacity 2.4.2 on macOS 10.15.7 with no problem.

Please try this. Create a new project. Go the the Generate menu and select Chirp. Accept the defaults. Play the project. Does it play OK?

– Bill

Same problem for me. This version of 2.4.2 is an absolute mess. I was still using 2.0.5 until I updated to Catalina. I wish I could still use the 2.0.5. Never had issues with that version but 2.4.2 doesn’t work at all.

I don’t know my way around macOS, but recent old versions of Audacity are available from OldFoss: Audacity download latest version. See the link OLDER VERSIONS on that page. If I understand correctly, 2.4.1 is the oldest version of Audacity that will work on Catalina.

If that doesn’t help, I imagine you could also google: how to revert back to mojave from catalina

Before you take any of the above steps, you might check out these forum posts:

I actually just came back to say I downgraded to 2.4.1 and it seems a lot better. No stuttering or delays in the editing and highlighting or playing and stopping of the audio like 2.4.2 has. And it only crashed once in the hour I was using it as opposed to the 6 crashes 2.4.2 had the hour before I downgraded. Seems at least initially that 2.4.1 is much better than the 2.4.2.

I wish I could’ve stuck with the 2.0.5 I was using before I updated to Catalina. :frowning:

2.4.2 worked fine on on Macbook Pro with 10.15.7 Catalina - as did the latest alpha test build I have for the upcoming 3.0.0 release.

And last week I upgraded to Big Sur macOS 11.0.1 and both still work fine there :sunglasses:


For that you have to blame Apple and not us - as it was them that prevented 32-bit apps from running on Catalina (or Big Sur and onwards).

It also annoyingly means I can no longer do Mac QA regression testing back further than Audacity 2.3.1 :imp:


Bill I tried that and the chirp was fine. I think what happens is that I get a file work on it, add some music, and after I’ve done about 4 things it crashes. I never get as far as exporting it. After the first crash the following ones are more frequent. I have started using an old Windows machine instead. Maggie