"Audacity Cannot be opened because of a problem"

Hi gurus. My typically very trusty Audacity has started acting up on me today. I have re-installed a couple times to no avail, but regarding that… but do I need to buy a good uninstaller to completely remove first? Or should it work when I run Audacity installer again and replace the existing file?
When I try to open I get:

Audacity cannot be opened because of a problem. Check with the developer to make sure Audacity works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.
Click Report to see more detailed information and send a report to Apple.

I am Running High Sierra 10.13.6 on a 2011 MB Pro. Model: MacBookPro8,1, BootROM, 2 processors, Intel Core i5, 2.3 GHz, 8 GB, SMC 1.68f99
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD,
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD,

This is what the report to apple that generates says:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x2] Wrong architecture

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice
Referenced from: /System/Library/Frameworks/CoreAudioKit.framework/Versions/A/CoreAudioKit
Reason: no suitable image found. Did find:
/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: mach-o, but wrong architecture
/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: stat() failed with errno=45
/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: mach-o, but wrong architecture

Thanks so much in advance for any words of wisdom!!


Which version of Audacity do you currently have?

I’m unable to check it now because it won’t open, and in the report under version it only says ??? but I had to confirm it was the latest version (2.3.1?) as of a couple months ago.

Try resetting Audacity according to these instructions: https://forum.audacityteam.org/t/resetting-audacity/50613/1

Then download the current version (Audacity 2.3.3) via the Audacity website: https://www.audacityteam.org/download/mac/
Installation instructions are provided on that page.

Hi Jeremiah.
I’ve been on a similar hunt today, due to Sample Manager (32-bit) stopping working, and Renoise 3.1.1 (32-bit) stopping working.

I decided to run Sample Manager by going to the folder /Applications/Sample\ Manager.app/Contents/MacOS/ on the terminal and running ./Sample\ Manager

The result was the exact same error you are getting. Here it is:

$ ./Sample\ Manager 
dyld: Library not loaded: /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice
  Referenced from: /System/Library/Frameworks/CoreAudioKit.framework/Versions/A/CoreAudioKit
  Reason: no suitable image found.  Did find:
	/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: mach-o, but wrong architecture
	/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: stat() failed with errno=45
	/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevice: mach-o, but wrong architecture
Abort trap: 6

Now. going to the folder /A/ and typing file MobileDevice yielded a further clue:
MobileDevice: Mach-O 64-bit dynamically linked shared library x86_64

So, any “Reset Audacity” advice that you’ve received is not going to be very useful.

Many people have gotten this error, right after downloading and installing an iTunes update for syncing their brand new iOS devices with. I, too, was helping a friend set up her 2020 iPhone up, and downloaded an iTunes Sync update. This Sync update has only shipped with a 64-bit MobileDevice.framework file.

I’ve been going around the internets a bit and some have gotten successful results by copying in an older, 32-bit compatible, MobileDevice.framework. I’ve even found a Reddit post where such a file is linked. I’m yet to figure out how to install it though.

I use Xcode 11.3.1 on this macOS Mojave 10.14.6 computer, so I can’t update to a newer version of Xcode which would hopefully give me a 32-bit MobileDevice.framework.

But don’t go around resetting your Audacity settings, this is unrelated to them.

Since I’m in a rush and need these apps working, I’m going to follow the instructions at https://forums.creativecow.net/thread/19/897177#897188. Wish me luck.

The “Get a previous MobileDevice.Framework, disable SIP, install it from Safe Mode Terminal, test that it works, enable SIP” solved it.

But good news, I recently got another iTunes update, and the May/June 2020 ModileDevice.framework actually has both 64bit and i386 there, so it no longer breaks 32-bit audio apps.

The current version of Audacity is 2.4.1, which is a 64-bit build. 32-bit plug-ins are not supported by the current version of Audacity.