Audacity 3.5: Cloud saving, automatic tempo detection, and more!

When I import the audio file as a new track, the tempo gets messed up. For example, I have made a comp file separately and then a solo file separately. Combining them in the right tempo is not possible. Version 3.4.2 did not have this problem.

This version wrecked ALL project saves by slowing the pitch and speed by some unknown percentage by itself. Everything works fine until I save a project and close it. Upon reopening, all the files are slowed down, which also extends some clips cut range due to them being slowed down. It’s a mess. Never had this happen on any other version of audacity and will certainly make me cautious about updating to newer versions in the future if my saves cannot be saved. Why is this happening?

In looking at the removals, I saw the following:

  • Removed “scrolling left of zero” preference.

If one should need to do this, how is it done now? I’d prefer to know this before updating.


@smokeringhalo I’ll look into it on monday.

@am_dew It’s not done at all. Negative time as a concept is something we don’t want to support going forward. At the moment, you still can slide clip into negative time to effectively trim it on export, but you can’t move the viewport back there anymore. What was your use case for it? It’s entirely possible that we might add a feature that directly caters to it instead.

@LWinterberg When I have two similar tracks that I am syncing together (aka a matrix) and I need to move one track left of zero in order for it to match the other track and i want to see what is left of zero. But I can easily work around this in a few different ways I believe.

1 Like

Hi, I tried to save to so I could record and save at home PC, then edit elsewhere on my laptop. I saved to but when I went to edit on a different device, it displayed no audacity projects even after syncing my account and all that. What am I doing wrong?

You guys rush these updates out but you FAIL TO FIX ISSUES!!! Which means I’m going to have to go back to 2.5 or whatever the hell. THIS is what I’m now experiencing and it’s inexcusable. On Windows…everything is updated, blah blah blah.

In previous versions, when I clicked “solo” on a certain track, it actually soloed the track!!! Amazing huh? Just what it’s supposed to do. But NOW (and also on the previous version) when I click “solo” it WILL solo that track but if I change my mind and I want to solo a different track (I click solo on the different track) it will then “solo” both at the same time. (and not really “soloing” either of course) In fact I can click and try and solo different tracks and it just turns them “on” leaving ALL the other tracks on too. Of course, there should only be one track that solos and if you change your mind and want to solo a different track then the one you originally started with, it should turn off completely the previous track. In other words you should really only be able to solo one track at a time - hence the name solo. Having to go back and “unclick” solo on the other tracks I don’t want to hear is garbage.

Also, how is it possible to mute AND solo the same track at the same time? That needs to be fixed…Please do this asap and Audacity is un-useable to me and I’m working with different programs now.


@Kschlewitz In Preferences → Track behavior you can set Solo Button to Simple to restore the old behavior. I just changed the default.

Being able to solo multiple tracks is a standard feature across DAWs. In various kinds of music production contexts, content of a similar kind is placed on multiple tracks - for example in an orchestra recording, where the brass section would be multiple people, mic’d up individually. Projects growing to 50+ tracks is quite common, and 125 tracks are often seen as not enough. In such an environment, soloing multiple tracks suddenly isn’t insane, but expected. And if you have tracks 1, 34, 35, 36, 37, 56 and 57 soloed, wanting to mute track 34 without unsoloing it makes sense, too - you’d lose the solo selection you’re working on otherwise.

I am creating song covers by playing different instruments since many years, hence using “Change Tempo” effect on the Loop is the first step. However, today I downloaded the 3.5.1 version and the Change Tempo simply does not work. The loop just goes back to its original tempo after being exported (for e.g., 90 does not change to 82). Tried multiple times without any success. So unistalled 3.5.1 and loaded 3.5.0, but the same issue. Finally I reverted back to version 3.4.2 which used to be fine and voila, the Change Tempo worked as it should!
I hope the 3.5.0 versions don’t have a different way of Changing Tempo and exporting the audio? Thought of highlighting this to the developers.
Always thankful for the wonderful Audacity! :blush:

When aligning two similar tracks in a matrix and needing to shift one left of zero to match the other, it’s important to view what remains left of zero. However, there are multiple workarounds available to address this issue effectively.

Sounds good. I had to revert to an earlier version b/c the last one you removed the ability to join clips by clicking. I can’t get my work done in a timely fashion with all the extra steps–did you reinstate join by clicking? Or is this something that might happen soon?

I recently updated to Audacity 3.5.1 and I’ve been trying to open some old projects that I haven’t touched in forever - the project opens but it gives me an error message and then replaces all audio with silence even though I can find the .au file and it’s exactly where it should be. I’m not sure if this an issue specifically with this version but does anyone have a solution for this?

it is great to listen

All this is to Effing much for me to handle, I just signed up out of frustrations from all my daws destroying my audio recordings, and I would spend an hour to setup my W11 every time due to daw and driver fights, So i was like tire of every time my computer would freeze it would just go…


I had the Audacity to say enough and remembered the old days in the 2000s my boy E would be like you just need to record the verse on audacity and send it to me ftp cause i did not understand frutiy loops, Now i know em all but they all are just a head ache, This recorded me in time no lag, and i could here myself and quality was like bam, i have not been able to ever record like this in 2 years, Feeling lame for waiting to return and check it out, i should have known being a fan of simplicity you freaking nailed it, So fast and furiouso I call mine Audiosity say Adios! to your old daw daw. Ok ill stop now. TY :heart_eyes: 2024-05-08T07:43:00Z

Works for me on Win10, Commit Id: d8f4c2. You’ve changed the UI for the vertical scale. has replaced for reset Zoom, but zoom in can now only be done via the menu; it was previously, I think. Six menu actions to zoom in in is a bit much for me. Could you add something like to zoom in? I looked for a way in key bindings but couldn’t find anything for that popup menu. Thanks! Phil

This update has ruined all of my recordings. Every time I close and reopen a project random clips are stretched out and tempos changed. This has ruined 100’s of hours of recordings, I used to recommend Audacity to everyone, but no way after this. I feel like this is an issue with this new auto Tempo feature, is anyone able to help?

It can’t currently be disabled, which leads to problems like this

1 Like

It is disabled and it’s not even just tracks that are being imported, it’s everything…

1 Like

This wasn’t helpful at all… I’ve now also tried multiple older versions of Audacity which don’t have this problem but just keep crashing… This has actually become unusable…