Audacity 3.4 is out now!

Installed Audacity 3.4.1 on top of 3.3.1 system is Windows 10 x64 22H2. Ran an existing macro that opens flac files, applies replaygain, then saves as flac. 3.4.1 crashes on running the macro. Reverted to 3.3.3 and back up and running. Sent the crash report using the “send” button in the program popup. lastlog.txt is here:

The defaults (Tools > Reset Configuration) were changed. You will have to make a custom change to your preferences: Edit > Preferences > Tracks Behaviors > Solo Button: Simple

Sounds like this problem: 3.4.1 Crashes trying to open 3.3.3 .aup3 project · Issue #5568 · audacity/audacity · GitHub

So probably you just want to revert to 3.3.3: Old Audacity versions download

1 Like

Thanks, @jademan. I’ve just reverted to 3.3.3 (I had old version downloads on my computer) after discovering I couldn’t import .wav files in 3.4.1 and I need these for sound effects in my podcast (again, this might be a Preferences setting like the Solo functionality?).

The good, nay, the fantastic news is that I can open the .aup3 file I created yesterday with 3.4.1 in 3.3.3, so I can get back to editing and publishing my episode.

Thanks again for your prompt response. As someone who’s been involved with the Joomla CMS for a decade and a half, I know open-source projects like Audacity can be difficult and thankless tasks!

:pray: ^Robert

3 posts were split to a new topic: Format option missing

From the above image…
I click on Multiple Files
A newer drop down appears with more options
Split files based on:

I can only choose Labels
Tracks (which is what I want) is greyed out and inactive as a choice

Tracks allows me to edit the metadata of each track prior to exporting.

Hey all!

We just published Audacity 3.4.2. It’s a second hotfix, this time fixing some usability issues and a few rarer bugs. Highlights:

  • #5555 Copy-pasting behavior now pastes into clips again by default. This can be changed via Preferences → Track Behavior → Always paste audio as new clips.
  • #5571 Fix clips shifting to the right when effects are applied to them.
  • #5106 Fix clicks occurring when overdubbing a project with muted tracks.

More details can be found in

Thank you. :grinning: Note: response to Help > Check for Updates display does not fit on screen and is not scrollable:

I just upgraded to 3.4.2. When exporting multiple tracks based on labels, I cannot get the metadata fields to repeat after the first track. The metadata fields on the second and after files for artist, album title, etc. are blank except for the track name and track #. Previously I would enter a year, and genre, an album title, and those fields would all repeat for all tracks with only the track name changing according to the label. The user manual says the metadata editor has a checkbox for “don’t show this when exporting audio”. I wanted to try that to see if it would fix the problem, but that checkbox does not exist.
What is the process for entering metadata fields to apply to all tracks/files being created on export of audio files split based on labels?

1 Like

good verry

3.4 Amazing! Thank you all, for your hard work :slight_smile: Best wishes, Danial.

I also upgraded to 3.4.2 and am having the same frustration when entering the metadata fields. The previous version was a great time saver when using Audacity to transfer my vinyl collection to MP3.
Is there a way to correct this?

Joining clips is pretty simple really. Just highlight what needs joining and hit control+J. Although I do admit that joining clips was easier the old way.

I also agree that the new export menu is completely balls.

But although the new features are useful to some people, at the end of the day, it’s an audio editor and not a DAW. All the new additions in Audacity I can do in a DAW which, personally speaking, kinda makes the features useless.

Another good point not mentioned in your comment is that the audacity team really needs to fix the issue with system resources on Windows. My computer is very powerful (32GB RAM, i7 Processor, 1TB NVMe SSD) and just editing a single 2-channel audio track temporarily freezes my computer. This never occurs on Linux. Like, ever. I can load a hundred files in Audacity on Linux without a single issue, but for Windows 11 Pro, the software sucks ass. I just don’t get it. Maybe I’m not as familiar with Windows as I am with Linux (this, for most people is completely ass backwards…lol).

But yeah, I agree, the new exporter is trash. Thankfully they haven’t updated the snap or flatpak versions yet. I’m definitely not updating it when they do.

Downgrade to the previous version and don’t upgrade until they squash the bugs. Problem solved.

This installation left me feeling a little let down. Two problems happened when I installed 3.4 over the prior version; these things also happened on previous installations that I don’t remember happening. First, Audacity displays a message saying all files must be in the same folder (?) if I use the menu option “File → Import → Audio‒” to import multiple files from the same folder. Secondly, it seems that the settings I had set in the previous version have been lost when I import/open a single file (a.flac in this case) and try to export it as an.mp3 file. Although I’ve never had to do so, I will in this instance be going back to an earlier version. Really unfortunate; audacity is a wonderful

1 Like

scusa se ti disturbo, non so a chi chiedere perche sono nuovo ,frescofresco del forum e capisco che sei uno pratico del programma, non riesco a sentire la traccia che carico anche se le configurazioni audio sono giuste, mi potresti indicare cosa posso fare? grazie

Incredibly frustrating how audacity f*cks up the whole thing with every bloody update.
And it’s getting worse with each update - this one is driving me mad.

  • clicking into the recording now results in 2/3 of cases in “enveloping” it, whatever the hell that is. Exactly no-one asked for it and it results in endless “undo”-s because all I wanted is placing the line from which audio begins. This single idiotic change makes working with audacity incomparably more tiresome.
  • merging adjacent blocks by just clicking on the border is not possible anymore. It was a very simple, very useful feature so it’s logical that it was de-activated. Sadists.
  • and the best: the “solo” button to the left is now thoroughly f-ed up, in fact it works now like the mute button whereas the actual mute button doesn’t do a thing. So practically there is no solo option anymore.

What a total shitshow. Any way to go back to the prior version that actually worked?

1 Like
  1. Sounds like you’re in either envelope mode or multi-tool mode. Press F1 to return to the normal Selection mode.
  2. You can merge the clips together by selecting all of them and then right-click → join clips. If you leave the clips be for a while, this requires even fewer clicks than always clicking on the clip border.
  3. Preferences → Track Behavior → set “Solo Button” to “Simple”.

In addition to that, older versions are available from Old Audacity versions download

My problem was in the ‘Export’. It is quite a learning session. But I got it.

  1. Since I use ‘Custom’ channels. It doesn’t seem to remember that each time I go to export. So I have to re-select that. (or remember to re-select that… ) Never had to do that before.
  2. The output file-name. Let’s say you are saving something a second time. It forgets the output filename.
    I’m happy it doesn’t make you reset the metadata every time, because likely, it sometimes it’s the same. At first I didn’t know where it was… but then I was like “OH”. yeah, that makes sense. But now I have to remember to change it when I’m editing a large recording of different pieces. That’s not bad though.