Audacity 3.1.1 keeps crashing when trying to open file [SOLVED]

I’m currently working on the narration track for my first video essay. This is the first project on which I’ve used Audacity seriously and I’m teaching myself to use it and figuring out a workflow as I go along.

Background: Last night, I was editing alternate takes together in a project file. I had trouble saving due to lack of hard disk space so I moved some things to an external drive in order to save. Eventually I was able to save. I do not know whether this is relevant, but am including it just in case. This afternoon I booted up Audacity, saw there was an update, so I went ahead and updated. I replaced my old Audacity file with this new one and I unfortunately don’t remember what my previous version was that I was working with.

The problem: After this, I tried opening my project file and I got a message saying that it had been shut down without saving and offered to recover the files. This is strange because I had saved each file a couple times before closing. The main file I am using as my master opens fine. But my file with the retakes has a problem and I have been unable to open it. Every time I try I get an error message and it crashes. I’m attaching a txt file of the error message. I tried copying the file and opening it on my other Mac but, after needing to update to the current Audacity version, I was also unable to open the re-takes file.

I unfortunately do not have another copy of this file and if I do not recover it will need to do another round of rerecording. I’d really rather not as this project has been stressful and time consuming enough as it is.

Your help is much appreciated.

MacOS 11.6.1
Current Audacity version: 3.1.1
Prior Audacity version: ?

Exception Code 0x1

See attachments for the crash log
Audacity Error Message.txt (375 KB)

As I have said with others, if you care to zip up your .aup3 project file and upload it to a public file sharing service, then post (or PM me) a link, I’ll take a look at it - no promises.

Having effectively the same crash immediately after installing 3.1.1

3.1.0 and earlier had been working fine on Intel iMac 2017 with Monterey 12.0.1.

Gives error specifying that earlier file didn’t save correctly, asks/suggests that it process file to open it, says to save it, then crashes with crash file to Audacity to send.

Looking in the directory, there had been an attempt to open the WIP .aup file, (and perhaps close it) which had a -wal appended to it, with 0 bytes.

The actual .aup file works well now that I have reinstalled 3.1.0 –
For a few days it is located at:

Play this with care, as the 2nd 10 seconds of the clips are 180° out of phase which may cancel though give a lot of energy to your speakers to do so.

Good luck to us all.

Thanks for your report. I am able to reproduce this issue with the project you supplied. And I have reported it to the developers on discord. They are already looking into this as I am writing this, so we hope to hear back from them soon…

In the meantime, as you say, it seems to work fine on 3.1.0.

Another observation: If I copy all of the tracks (Ctrl+A, Ctrl+C) to a new, empty project (Ctrl+V), then save this new project - the new project seems to load in 3.1.1 OK.

Edited: This issue has also been logged on Github: and

Update: The developers have identified an issue and are currently testing a possible solution.

I cannot figure out how to PM you. I just registered my forum account the day I made the post so that may be the reason. Here is the link to the zipped project file in my Google Drive:

Downloading now…

I have to run out for the day - I’ll be back later.

So I can confirmed that your issue is the same as that of cinematesttools. Reverting to 3.1.0 will allow you to open your project. You can download 3.1.0 here:

I will try to post more information later…

The developers have created a test/alpha version of 3.1.2 which has a correction for this bug:
This alpha 3.1.2 not only allows the (i.e., your) project to open, but also saves it so that 3.1.1 can open it without an error :exclamation: :ugeek:

OK, so here is what I did:

1) I downloaded this test version from the artifacts at:
    (there are four of them here: I downloaded the one appropriate for my system).
2) I unzipped the file.
3) I unzipped the resulting zipped file. (I don't know why, but it gets zipped up twice).
4) I ran Audacity.exe from the second unzipped directory.
5) I opened your project (which caused problems on 3.1.1), which opened with no errors.  :D 
6) I saved the project (these two steps took less than 30 seconds)
7) I closed Audacity, then opened the project in the released Audacity 3.1.1 - which ran fine.

So this appeared to “fix” the problem. Note: these are the steps I used on Windows. You would have to adjust the steps for MAC. :smiley:

DISCLAIMER: Alpha versions of Audacity are intended for testing purposes only and should normally NOT be used for production work.

Note also the copy, paste to new project steps that worked for cinematesttools. But also note that due to the size of your project you might need 50GB of free storage before attempting that. :wink:

Or you can revert to 3.1.0 and wait for 3.1.2 to be released. :wink:

Good luck :exclamation:

Just in case the developers are watching - Audacity 3.1.1 just crashed my own project - which I repaired by running the stated 3.1.2 alpha one time - then reverting back to 3.1.1 works like a champ!

I don’t believe that the developers watch this Forum - you will need to report an issue on GitHub.


Well, Dmitry already knows about the issue and seems to be taking it seriously - so I’m not too worried. :wink:

However, since you suggested…


I am having a very similar problem. I saved a aup file and went back in to edit it today and had the same recovery message pop up. Every time I try to “recover” the file Audacity crashes. I’m curious if there are any updates on this error being looked into. Will there be a new version of Audacity to download to fix this error or is there a pro tip for Windows 10 users to get past this error.

Thanks for the help

Audacity version 3.1.0

Please see:

Note the developers are hoping to have a fix available today or tomorrow.

I’m using Audacity 3.1.3 and macOS 12.5, the same problem for making a save when my Mac [advert removed] disk space is close to full. I can’t change or delete clip names (these are the new clip names that were introduced in version 3.1.0) and to make matters worse, if I try to do so with sync-lock tracks enabled, Audacity crashes every time. Someone on this board mentioned they weren’t having this problem running Windows, so it may just be Mac related.

Working with audio (or video) requires a lot of disk space. If you run out of disk space, then bad things will happen (in any app on any OS). Running out of disk space is a user error, not a bug.