Audacity 2.4.1 for Mac OS Catalina - Very Slow Interface Responses

I have been eagerly waiting to update my Mac OS to Catalina but as an avid user of Audacity I have waited until now due to the incompatibility. I have to say the performance is extremely disappointing in comparison to version 2.3.3 which I used on Mac OS High Sierra without any issues.

What is occurring is a very laboured and “jittery” performance particularity when I am trying to select portions of recording to edit and to select an area of recording is very slow, and laboured in comparison between versions stated. Can anyone suggest a way I can resolve this on my machine (I have 32GB of RAM installed so it’s not a memory issue).


I’m not seeing this on my Macbook Air with Catalina. Could you give us more details of the project you are working on?
– Bill

Me neither.


I too haven’t seen this particular issue. I just opened a case on an issue I’m having trying to right click open to Audacity… not working.

Here is an example of what I am finding. I have an audio file (mp3 format) which I’m looking to cut a portion from. When I use the mouse to select the area I wish to cut, the performance is slow, ultra slow and jittery, in comparison to what I was getting with the previous version of Audacity on Mac OS High Sierra which was slick and fast.

File attached to demonstrate: Dropbox - File Deleted - Simplify your life

It is not obvious from your video, but it appears you are trying to select a region by clicking in the waveform then dragging the mouse pointer outside the window to extend the selection and force the waveform to scroll. Is that correct? I’ve tried with with 2.3.3 and 2.4.1 and don’t see any performance difference between the two versions on macOS Mohave nor on Catalina.
– Bill

I’m dragging it outside the window in order to move the cursor to where i want to edit, i.e the portion of edit ends further along the wavelength hence dragging outside the window to select the area I want.

This issue is with the protracted time it now takes, slow and jittery to move even a few seconds (clearly seen in the video clip) along the waveform in comparison to the smooth slick scrolling I could achieve in High Sierra with the previous version of Audacity. I find the whole performance speed to be significant compromised in Catalina with the latest version producing ultra slow manoeuvrers, e.g. fade in, fade out, amplify etc. It’s just so slow and jittery and I really do not understand why. I use Audacity so much I am going to be forced to reinstall High Sierra in order to get my audio files edited in a timely manner.

In addition to my initial query I note and have observed that adding a track by dragging and dropping into a blank Audacity Window rarely works and to add it requires going the “long way” via the menu bar…but that’s not for this issue…

This could easily be something I’m missing but I don’t know what. All I can report is performance issues mentioned here are very poor in comparison and obviously nothing is changing with the hardware.

Sorry I’m unable to help. I just don’t see the performance hit you’re seeing in 2.4.1 versus 2.3.3. The type of select-scrolling you’re doing looks the same to me in both versions. I don’t think it’s a Catalina issue.

– Bill

Cheers Bill,

I’m just going to reinstall High Sierra where I suffered no performance / speed hit using Audacity. I’ll obviously use the latest version of Audacity when I revert my OS. I appreciate people taking time to try and help me with this.

Cheers Guys


Help… I have trouble exporting .AAc/m4a files after updating to 2.4.1.

I tend to get a message “Can’t open audio code “aac” (0x15002). Experimental Feature”. And this is after reinstalling FFmpeg a few times. Any idea what i can do?

Also there seems to be an issue where i can’t drag new tracks that I recently purchased via itunes directly into audacity. I’ll have to drag them onto my desktop before i can drag it into the audacity window. Thanks in Adcance!

OOPS yes indeed - I can readily reproduce this. This is a serious regression on version 2.3.3. It also affects the latest 2.4.2 alpha test build that I have.

I will be logging it as a P1 bug - so it MUST be fixed for 2.4.2 (which thankfully is scheduled to be a short maintenance release - the target is one month.

Good catch merfinism - and thanks for the report :sunglasses:


BTW since you have iTunes the workaround is:

  1. Export as WAV or AIFF
  2. import to iTunes
  3. use iTunes to concert to AAC
  4. delete the WAV or AIFF from iTunes

Cool. Thanks Peter

Logged as P1 bug
Mac: Attempting to export as M4A(AAC) yields an FFmpeg error message


Okay, Ive reverted to Mac OS High Sierra and have installed Audacity 2.4.1 and have produced a similar effect to my previous video file (Catalina and 2.4.1) and it’s visibly clear that the operation of selecting part of the waveform and then scrolling outside the window are significantly faster, slicker and without lag on High Sierra compared with Catalina.

Here is the High Sierra video file. If anyone can suggest why I should be noticing such a significant performance lag on Catalina compared to High Sierra, it would be much appreciated.



I think that part of the problem is that Apple now use 10 bits per pixel per R G B rather than 8. This significantly slows down screen draws, though that shouldn’t be a problem if you replace your Mac with the latest model.

It happened to me too. Not sure why. I also use this verision in my windows. There is no such problem. Every time when I tried to select a potion of the audio file. It just run slow. It makes me really uncomfortable.

It happened to to the 2.3.3 version. I was told that Audacity is slow in IOS system. Could that be true?

Audacity 2.3.3 and 2.4.1 work fine for me on a Mac Mini, but my display is not ultra high dpi.

Hi there,

I’m having the same performance issues with my iMac on Catalina. Audacity performs extremely slowly.
The Mac is from 2017, so not very old. Before, I used audacity on a MacBook from 2017 (on High Sierra).
It was performing fine. I’d like to know if this is an issue which can be fixed (by the Audacity team or Apple).
Otherwise, I’ll have to switch my editing software. :frowning:
I appreciate all your feedback.


Which version of Audacity?

What was the display size of the two machines (both pixels, and physical size)?
Do either of the machines have a Retina display?

Is Audacity more responsive when running in a window rather than full screen?

Is there any improvement if you open Audacity in low resolution?
(See: “Using apps with a Retina display” Using a Retina display – Apple Support (UK))