Audacity 2.3.3 on Catalina 10.15.3, not recording

I last used Audacity to convert some cassettes without a problem 11/18/18. Yesterday I found some more cassettes to convert, but I was unable to get it to work, so I upgraded to Audacity 2.3.3. Unfortunately it is not recording my cassette, I’m just getting a straight line, playback is silent, and during some of my trials, get a warning (screenshot attached) that “Recorded audio was lost at the labeled location. Possible causes: other applications are competing with Audacity for processor time. You are saving to a slow external storage device”, neither of which is true. I have tried uninstalling and reinstalling Audacity, restarting my Mac, nothing helps. I hope somebody can offer a solution. Thanks!
Screen Shot 2020-03-22 at 9.16.06 AM.jpg

See this workaround:

This problem is fixed for the upcoming 2.4.0 release.


I tried the workaround. But when I performed “3) in the Terminal dialog type the following command following command:
open /Applications/”, Audacity did not open.

I closed Terminal, reopened it, tried the command again and got this: Last login: Sun Mar 22 13:22:27 on ttys001
karenpapa@Karens-MacBook-Pro ~ % open /Applications/
The file /Applications/ does not exist.
karenpapa@Karens-MacBook-Pro ~ %

What am I doing wrong? Maybe I should just wait for 2.4.0 release be out?

Thanks again!