Audacity 2.1.2 problems with LAME library recognition

Just received an Encore cassette to MP3 player for use with my Mac desktop running OSX Yosemite (10.10.5). There was an earlier version of Audacity that shipped with the unit (2.1.0) that had other issues. Now I am able to get through to the part where I am setting the Preferences>Libraries>MP3 Export Library, and it refuses to recognize the LAME 3.98.2 version that it is looking for. I downloaded that from the link to the website—still would not recognize it. Then I changed the location of where that was loading to the Audacity folder, but when I follow the Browse option and got to the .dylib file, it was greyed out and I could not select it. If I changed the File type in the menu at the bottom to “Dynamic Libraries (*.dylib)” it was no longer grey, but “Open” was now greyed out and I could only choose “Cancel”.

Any ideas?

Did you get Audacity 2.1.2 and the Lame library (scroll down) from here?


Yes. Pretty sure that is where it came from. I had initially downloaded the older version and had problems with it. I came to this forum and saw the note about the newest version so I downloaded that. It would have been from a link on this forum. Also where I got the Lame Library.

You only need the Lame software to create a new MP3 file, but there are reasons to create other files. MP3 always creates some sound damage and you can’t stop it. Better to make perfect quality WAV (Microsoft, 16-bit) files of your music and then make MP3s from that. You can’t back up. Once you make an MP3, the compression damage is burned in permanently. you can make a WAV into anything.

Also, note that Audacity is going to try to export your sound files into the Audacity Application folder, not Music, Desktop or anywhere else. The Mac may not like that. I use my Desktop for everything and then clean up later.

When you start making sound files, you should avoid putting punctuation marks other than dash and underscore in the files. For example, today is 2016-12-28, not 12/28/16. ISO wrote a standard for that. This may not make any difference in your Mac, but the first time you send a sound file to somebody else, it may matter a lot.


had problems with it

Such as what?

Audacity puts plugins, add-ons, modules and software in places separate from the program. The idea is to let you gracefully upgrade Audacity without needing to reinstall your whole world again. You have a simple job but anybody in theatrical production can have multiple custom packages and this would be awkward.

Did you go through this?

Last time I did it, I dragged everything over to the plugin folder and installed it there.

Did you go through all the steps? It comes down carefully packed as a DMG (Disk Image). You explode that and it forms an installer. That’s supposed to “know” what to do. If you get it down to the actual software, you’re probably doing it wrong. Just knowing what a Dynamic Link Library is means you probably missed something.

I think we’re going to wait for one of the elves who knows this at the component level better than I do.


Problems I had with the 2.1.0 version were that it would not recognize the cassette player that I had attached through the USB cable. Not sure if downloading the newer 2.1.2 version had anything to do with that working after, could have been that I just restarted Audacity and it recognized it the second or third time around.

Also, I did “explode” the DMG and go through the installation process as instructed. I did not know there was a problem until I went through the instruction manual that came with the USB Cassette Converter and got to the “detecting the MP3 Library” part.

I will try going through the Audacity manual that you gave me the link to.

This is getting to the point where I am ready to return this little gadget and give up. Already wasted my whole morning and have not really gotten anywhere…

Audacity checks for new connection when it starts. If you plug something in after Audacity starts, it won’t automatically see it. Restart Audacity or Transport > Rescan.

wasted my whole morning

There’s nothing about this process, either cassettes or vinyl that’s quick, convenient or easy. The only way this pays well is if you have shows, music or work not available in another form. For you it’s a very serious, long hike.

For example, you’re probably not going to want all the songs on the tape smashed into each other with no breaks (assuming music tapes)? That means you need to go down the capture work by hand, find and mark each song break. If you hold a 30 minute tape in your hand and look at it, you will be spending between three and five times that length to make the finished show.

Nobody said you need to do them all at once. You can hold Sunday afternoon every week to transfer, clean, cut and save a tape show.


Thanks, Koz.

The wasted my whole morning part referred to the difficulty in getting the software to work with the cassette player, 2 different manuals to read, bad English in at least one of them, things not looking like what is in the manual’s illustrations, concerned I am screwing things up as I go…

Good news is that my first attempt at recording something off a tape worked. Yay!

Now it’s just a matter of figuring out what I need to do to continue. We have sooooo many cassettes that I would like to reclaim. I am willing to put in the time to convert them, just frustrated by the getting set up part.

I think, with your help, that I am moving in the right direction. Once I get going, there’s no stopping me.

Thanks again.

Running into same problem. Running macOS Sierra. Thought it was permissions issues as default folder on installer comes up as read only but if install to another location that is supposed to have read/write it is still greyed out when going to Preferences and telling Audacity where the library file is.

Don’t use the LAME DMG. It can only install to one place - /usr/local/lib/audacity and that location is locked out on some Macs.

Go to Download the “” file, where it says “(ZIP version here)”.

Expand the downloaded ZIP if your Mac has not already done that. Copy “libmp3lame.dylib” into the top level of the Audacity installation folder, so you see it alongside LICENSE.txt and the other files and folders. That’s all you need to do.


See the previous post

If that does not help, you may be being fouled up by Gatekeeper. In that case, see That problem, if you have it, will cause Audacity’s shipped plugins to be missing from the menus, and LAME and FFmpeg to be not found.


Gale: Just tried what you suggested, and when I click on “Locate” for the LAME dylib file, it shows that it is in the Audacity folder where I placed it, but it is still greyed out so that I cannot select it. I successfully made an MP3 file yesterday from one of my cassettes. Is it possible that it is actually finding the LAME file somehow and I just can’t see that?

In the same place, Preferences>Libraries, it is also telling me to locate the FFmpeg Library, but when I click on “Locate” it says “Success Audacity has automatically detected valid FFmpeg libraries. Do you still want to locate them manually?” So I am thinking it found what it needed there, but not the LAME files…

You should not need to select it. Detection should be automatic if you put libmp3lame.dylib in the top level of your Audacity installation folder. However, unlike FFmpeg there is no “Success” dialogue if you do click the “Locate” button for LAME. All you need to check is if you see “LAME 3.98.2” against “MP3 Library Version” in Libraries Preferences. If you do, you are good to go.

I do see there is a bug in the file filter in the dialogue to select the LAME file in Audacity 2.1.2. This bug is not in the previous 2.1.1 version. The “libmp3lame.dylib” file is greyed out if the file type chosen at the bottom of the dialogue is “Only libmp3lame.dylib”. To ungrey the file, choose one of the other file types, such as all dylib files.


Thanks for that tip. Did not work for me however. I did find if toggled the File Types to ‘All files’ instead of the dylib string it changed the greyed-out file name to black and allowed selection. Now it is working for me. In theory it should not have made difference but it did.

I think I am good to go! Thanks to you and Koz for your help.

For me on Sierra 10.12.2, choosing the filter for Dynamic Libraries ungreys the libMP3lame.dylib file. Anyway, I added the problem to our bug tracker.