Audacity 2.0.03

I have version 2.0.0 installed on my computer. Upon downloading the newer 2.0.3 version can I just install it over my 2.0.0 version to keep my settings or do I have to uninstall and reinstall. I have 3 computers and I had to play around with the sound settings differently on each one to get them to record. I have windows 7 professional x64 on all machines (which are Intel I3 built units) and they are all working good with version 2.0.0 right now. If I have to uninstall I don’t know whether there are enough benefits to go through that again. Hope someone can help and just installing over the older version would work.
Thanks in advance,

Please see Audacity Manual .

We recommend installing over the top of previous 2.0.x versions into the same folder. This retains your settings unless you explicitly choose “Reset Preferences” in the installer.

There are some minor issues that may result from changes since 2.0.0 on a few machines (for example, if you have adjusted the left-right balance on your system volume control, Audacity 2.0.3 may reset it). However the 2.0.3 output slider should now (as intended) control the master system output volume slider whereas previously it may not have done.

Even if you installed 2.0.3 then uninstalled it and reinstalled 2.0.0, your settings are never affected by an uninstall.


Thanks Gale for your help. I hope that when you upgrade to a version that can’t be overwritten that it will be in the manual also.

I installed version 2.0.3 over 2.0.0 and after getting windows 7 to set my microphone to default it finally will record as did the 2.0.0 version, but now even though my speakers work on everything else it won’t play a recorded song through the new audacity. the green left and right bars work but no sound. Tried everything else and the system speakers work fine. This is the same problems I was having on all 3 computers and had to fix each one differently, but this one baffles me. Hope you or someone can help.

The installer overwrites old copies of files that it installs.


Audacity should record from your microphone providing it is enabled in Windows. If it is enabled but not default, Audacity should record from it but you will have to choose it by name as the input device in Device Toolbar . If it is enabled and default then you can choose it in Audacity either by name or by choosing “Microsoft Sound Mapper” (if you chose MME host) or “Primary Sound Capture Driver” (if you choose Windows Direct Sound host).

In Device Toolbar, choose for output device the speakers device for your inbuilt sound device.

Reboot the computer if you still do not hear sound in Audacity.


Thanks again Gale,
My one computer worked out perfectly. The second one took away my default rear mic as no mic attached and would not let me select it as default, but it gave me a new mic source as front mic. Windows trouble shooter fixed that so that it now records that way. The playback problem of no sound but both green bars working turned out to be in the volume mixer. For some reason it turned the audacity volume to off and when I raised it back to match the rest it worked. So that computer also works now. My wife’s computer I’m leaving alone because it caused me the most problems last time and she is happy with the version she has right now and uses it everyday.

I have a new problem on one computer. When I installed version 2.0.3 it took away my rear mic as default claiming that I couldn’t make it default any longer as there is no mic plugged in. Then it gave me a new option for front mic which it allowed me to make it default. It recorded just fine. Now the problem is that when ever I boot up the record option doesn’t record. I tried changing from stereo mix to front mic on top but that didn’t work. Yet all I have to do to make everything work is to reboot. The first boot never works and I can’t find the audacity configuration file to see what is in it. Hate to keep bothering you but this is frustrating. According to windows the front mic is working properly and can find no errors.
Thanks again in advance for what I hope we can do to fix this. Had no problem in version 2.0.0.

Audacity does not give those messages - they come from Windows.

To me this sounds more likely to be a problem with your sound card drivers than with Audacity. There have been Windows Updates recently that have caused problems by changing drivers for a few sound devices.

If Windows Update is a problem, you could check if you have older sound drivers that you could roll back to in Device Manager - there is some help here: Missing features - Audacity Support .

Unless you reset the Preferences in the 2.0.3 installer, your Audacity settings will not have changed.

The audacity.cfg file is in UsersAppDataRoamingAudacity but you may have to show hidden files and folders to see it.

Is this front mic a physical hole where you could plug-in an external mic? Have you looked in the Windows Control Panel for the sound card’s own control panel for any extra options for the mic ports?

If (and only if) none of the above helps, you could try downloading this replacement Audacity executable:

Quit Audacity, extract “audacity_revert_r12160.exe” from the downloaded zip file into your Audacity 2.0.3 installation folder then run “audacity_revert_r12160.exe” instead of “audacity.exe” (which is the installed 2.0.3).

This would show if a specific change we made for 2.0.3 is the cause of your problem. It would not prove very much though unless you have the correct (best-working) drivers for your sound device.


I downloaded the audacity_revert_r12160.exe file and ran it but it wouldn’t load and said I was missing a .dll file. I tried uninstalling 2.0.3 and reinstalled 2.0.0 but had the same problems with having to reboot to make it work. I did a system restore to a few day before I installed your new software, but I still had the new same problems and having to reboot to get it to record. Your new software did something to my sound system that only effects your program. I then Plugged a 1/8" stereo adapter into my rear mic and had windows trouble shooter see that something was plugged in and it reset it to the default setting as long as I leave it plugged in. Now it seems having done that your program version 2.0.0 will work on a cold boot. I have no idea what the new version did and I have to wait until monday to call intel tech support about updating the sound system software and see what that does. Your new version still works on my main computer so I’m leaving it as is and will be careful about future updates as long as I’m happy with what I have. Maybe someone on your end can figure out what that version does. The odd thing is that all 3 of my computers are identical intel I3 boards and processors with the same version of windows 7 pro x64 on them and yet your program from the start gave different problems with the recording on my other 2.
Hope you find something,

I’ve gone back to version 2.0.0 as 2.0.3 messed up my audio system and wouldn’t let me update the audio drivers. I don’t know if version 2.0.2 was better but there is definitely a problem with 2.0.3 with my
Realtek audio drivers. I’ll have to stay with what works until maybe you can find the bug problem and let me know if version 2.0.2 has the higher audio quality as 2.0.3 did over the 2.0.0 version.

There should be no good reason for that, I just tried it on a machine without programmer’s tools on it.

If the problem was Error 14001, you could try downloading and installing the appropriate
32-bit or 64-bit Microsoft “Redistributable Package” as follows:
Audacity Manual .

Please make sure you actually pasted that “revert_r12160.exe” into your Audacity installation folder and did not just run that .exe from an empty folder. You can also pop that .exe into the 2.0.0 installation folder and run it from there instead of the installed audacity.exe. Just make sure you quit Audacity before doing that.

On your evidence above, I would say not.

If you can get that “revert_r12160” build going that would give us some clue.

So the variation could be in the audio drivers being used for each.

Audacity does not control what you do in Windows nor does it modify your audio driver files.

If I was in your position I would go to the computer manufacturer’s web site (or the motherboard manufacturer’s site if this is not a branded computer) and see if you can get correct Windows 7 audio drivers for that motherboard.


I’ve got a new problem with both of my computers (intel I3, windows 7 pro x64,6gigs ram). I updated my audio drivers a couple of weeks ago and everything was working fine with 2.0.0 version. All of a sudden I can’t record on one at all and the other looks like the red bars are moving but the sound level is extremely low and the playback sound in unbelievably tinty with no full sound at all. I even did a system restore way back and it still didn’t fix the problem. I use this program everyday and now I can’t. I completely uninstalled it and re-installed it but also no good. What could I possible do to fix this?
Thanks in advance for whoever can help,

Are these branded computers like Dell or HP or did you build them yourself?

How did you update them? Who is stated as the driver provider in Windows Device Manager?

Are you recording with an external mic plugged into the pink mic port, or are you recording something else?

Have you tried


Audacity Manual ?


My user name is magnum2tom. I have 3 identical computers which consist of Intel’s I3 board and chip with 6 gigs of ram, 1 gig Nvidia graphics card, 500 gig hard drive, Realtek built in audio system The board is a x64 board and my operating system is Windows 7 professional x64 on all computers. On 2 of my 3 computers Audacity 2.0.3 works perfectly, but on the 3rd I can load up an mp3 file…play, edit and save perfectly, but will record 1 out of a hundred times. When the recording does work it works as it should all day long until I shut it off. On all systems the only way the recording works is to go into the sounds section in control panel and disable the mic and set stereo mix realtek high definition audio to default device and then click on properties to increase my level to high. I also go to the playback area and enable along with the default speakers the realtek digital output for the default communication device. I’ve tried everything I can think of. I’ve updated my audio drivers to the latest 2012 driver from the 2009 one I had (and I’m sure last update for this board). Even the 2009 driver worked fine on the 2 computers that work with Audacity. Gale on this site told me to download a zip file with a rev type program that might help but it wouldn’t load because it reported that I was missing an important dll file so that did no good. I love Audacity and have used it for years and don’t want to have to try another program just for the purpose of recording a song from the internet and save it to an mp3 format to load up in Audacity to edit and save it. I hope some can help me come up with an answer since Microsoft and Intel can’t. I’ve also uninstalled and reinstalled version 2.0.0, 2.0.2, and back to 2.0.3 with no difference.
Thanks in advance (hopefully) for you help.
Tom (magnum2tom)

I’ve “disguised” your e-mail address. It is a bad idea to post your e-mail address on a public forum as it is likely to attract huge amounts of spam mail.

So what exactly happens on the third machine when you set it up like that and try recording?

I’ve just tried using the audacity_revert_r12160.exe on the problem recording computer and reset the mic as default and now when I try recording I get the red recording bars on the top as it should be but with no actual recording being done. So it is one step better but not quite there yet. Thanks for the info on the email…I edited my original post and took it out. The other 2 computers require the mic disabled and the stereo mix enabled and they both work perfectly set up that way.

Merged the topics. Please don’t start a new topic on the same issue with no reference to the original topic, also leaving questions in the original topic largely unanswered.

Please answer the questions here .

Please consider writing in paragraphs so that information can be scanned more readily.


If the audio device was working correctly and all you want to do is record stereo mix, all you “should” need to do is enable “Speakers” and “Stereo Mix” in “Windows Sound”, then everything else can be disabled there. Then in Device Toolbar choose “Speakers” for output and “Stereo Mix” for input. Making Stereo Mix default input in Windows does sometimes help, but it should not be necessary.

Exactly what are you trying to record? Stereo Mix or the microphone?

If it helps, the following are required to record stereo mix:

  • play the sound on the “Speakers” not on the Digital Output. This means setting the “Speakers” as default playback device in Windows “Sound”.
  • unmute and turn up the output level of “Speakers”.
  • unmute and turn up the output level of the Flash player in the browser.
  • unmute and turn up the input level of Stereo Mix.
  • In Audacity, choose “Speakers” for output and “Stereo Mix” for input.


I’ve deleted your latest post that is an exact duplicate of .

If you still need help I suggest you click this link (the first post in the topic) then re-read all the replies you were given, and let us know the answers to the questions in those replies. Otherwise we are just going round in circles.