Assistance please with ripping vinyl using WASAPI - Not reco

I am trying to setup ripping vinyl using the WASAPI option so I can get true 24/96 resolution (please, no arguments on the merits of 24/96 resolution vs CD quality 16/44.1, etc.). I am using an A to D converter, the AD GTL 40, with a USB connection to my PC running Windows 8.0. Audacity version is 2.0.6. Everything is functional as I can rip from vinyl using MME.

The settings I have are as follows:
Audacity Device Toolbar - Windows WASAPI - Speakers (High Definition Audio Device) - Speakers (High Definition Audio Device)(Loopback) - 2 (Stereo) Recording Channels

I have also changed the Playback and recording options to Speakers (3-ADL GT40 USB DAC). Neither work.

In Audacity Preferences in the Recording section I have “Software Play through” selected. When it is not selected pressing the record button creates a new track, but does not start the Timeline Marker. With the Software Playthrough selected, the Timetrack Marker moves as if it is recording, but nothing is recording.

In the Windows Sound applet, under the recording tab the GT40 appears under Line and is enabled. When I am playing a record the sound meter shows that the device is playing through Windows. Indeed, I can hear the music through my speakers,

I have been trough numerous articles and posts on the Audacity forum, Computer Audiophile, Head-Fi, etc. and have found nothing that can resolve this. Any suggestions, assistance, etc. would be greatly appreciated.

Thank you.

WASAPI loopback is meant for recording computer playback, not physical inputs.

You “could” record using loopback by sending the converter input to the built in audio device. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the converter, then choose “Properties”. Then click the “Listen” tab, enable “Listen to this device” and set the built-in speakers as the playback device for Listen. Then restart Audacity and set Audacity Device Toolbar as you already have it.

This probably remains digital after the audio reaches the sound device, but you’ll record the e-mail alerts and other system sounds unless you turn them off. Also WASAPI loopback at other than 44100 Hz can glitch for some users, so you may get no further forward.

Audacity 2.1.0 to be released soon has experimental support for WASAPI recording from physical inputs. You can try a 2.1.0 pre-release version “rc2” from the top of or sign up to our announcements at the bottom of then we will e-mail you when 2.1.0 is released.

There are are a number of bugs open for WASAPI recording of physical inputs so your experience may vary. You may get better results by setting Exclusive Mode either on or off for your converter’s recording device (in the “Advanced” tab of Windows Sound). In theory, Exclusive Mode would be better because it bypasses kernel processing.

Feel free to report any issues you find on this Forum or contact our feedback address.


It’s certainly worth a try. (As Gale knows) I have been using WASAPI as my host of choice using the alpha versions of 2.1.0 both for loopback and to record the input from my Edirol UA-1EX external USB soundcard (these days fed from my FM tuner rather than my turntable) for some time now. The results have been excellent and I have experienced no real bugs.


Everything is functional as I can rip from vinyl using MME.

In that case, I recommend using the method that works. :stuck_out_tongue: