Allen & Heath QU32 board issues

Running Ubuntu Studio 16.04. Recording 18 channels via USB cable. About every 2 minutes, all 18 channels get a buzzing noise on them which covers up the sound on that channel. The louder the volume on that channel, the louder the buzzing. This noise will last for about 10-15 seconds and then fade out. 2 minutes later, same thing repeats again.

I have tried changing everything in the Quality section: have tried every combination: no difference whatsoever.

This noise occurred when I updated the machine to 16.04. I do not believe that it anything to do with the machine. I was using a different PC and had this problem, so I readied a much better machine and tried it. Same thing: no difference at all. This sound is not seen in the spectrographs: only heard.

I had to record today using the stereo outputs on the back of the board and the sound was fine.

Any suggestions would be appreciated.

Post two test clips. Post one with the work clean with no distortion. Post a second one with the distortion at its worst. Post WAV (Microsoft), 10 seconds stereo or 20 seconds mono.

Scroll down from a forum text window > Upload Attachment > Browse.

It’s not open ended. You can’t post hours of work.


11-19-2015 is the good one.

I appreciate your help!

USB is not infallible, especially with extreme numbers of channels. Are you using USB 2.0 or only 1.1? The distorted section of your bad sample has a few dropouts as well.

How long is it since you completely shut down and restarted the computer?

The nose is prominently seen in the Spectrogram.


What puzzles me, is that the interference is cyclical…

Otherwise, it sounds like typical USB noise, due to a bad or too long USB cable, a dying PSU in the computer or some ground loop problem.

That it started after an update is also rather atypical. Is there some other software that might be scanning the USB bus?

None of this happened before updating to 16.04 and whatever Audacity version came with that. I installed Ubuntu Studio after that and the same thing persisted. Installed Ubuntu Studio with no change. Installed on another, faster machine, same thing.

Machine has everything turned off that is not necessary: bluetooth, auto updates, print manager, etc. USB 2.0 using approx 4 foot cable. Only thing that changed was 16.04. Both machines had clean installs: not updated from 14.04. Second, faster machine also has 2 HDs: one running the program and the other for writing the recorded sound to.

Machine is only used on Sundays for church service: it is off the rest of the week. So, it is rebooted/restarted every time it is used.
Thanks for listening!

I don’t expect it to be directly relevant, but what version of Audacity are you using (all three numbers as given at Help > About Audacity…)?

You could try increasing “Audio to buffer” in Audacity’s Recording Preferences.

Does other audio recording software than Audacity have this issue? I am not aware of USB issues on Ubuntu 16.04 but the best place to ask about that is the Ubuntu forums.


Thinking about the two minute period, I searched a bit. Could this be related?

Maybe you could try altering power saving setup to see if it changes the period?

Version 2.1.2. I am at work right now: on lunch break: and may have to check the bug report later. I have the power manager shut off.

Just ran through another church service using the stereo outs: everything was good. Switched to USB 18 channel: tried changing everything: quality, sampling rate, recording Hz: all bad: same distortion, same frequency of occurrence. When it is not distorting, everything is good: quite good in fact.

I also re-installed power manager which made no difference.

I am at a loss. With Xubuntu 14.04, I had no problems at all: even with much less of a machine running everything.

I have tried Xubuntu and Ubuntu Studio: both of them in 32 and 64 bit versions and on both machines. Regardless of what system and what machine, the problem persists exactly the same.

Did you increase “Audio to buffer” in Audacity’s Recording Preferences as suggested?

Exactly what recording device are you choosing in Audacity when you record the USB output? Do not choose the “Default” device because that will be Pulseaudio which adds a middleman software mixing interface into the equation. Choose the (hw) device which accesses the USB device directly.

Do other recording applications than Audacity have the same issue?


I am recording the USB stream from the board. When I hook up the cable, Audacity shows me 4 connections for the board: QU32 mic 0, mic 1, line 0, and line 1. I have tried all 4 of them: just today. I tried increasing and decreasing the latency: nothing there either.

“Latency correction” is the wrong setting. Try changing “Audio to buffer”.

It would be good troubleshooting to see if other recording applications have the same problem.


I took the "audio to buffer all the way up to 170: should I have gone more?

What I am not understanding is that I had no problem whatsoever before the upgrade to 16.04. Lesser machine, same set up completely: pretty much “out of the box”. The only thing I remember changing was the input source to 18 channel USB input. And, it just worked fine.

You can only experiment.

You could ask on the Ubuntu Forums, but 18 channel over USB is demanding. You should probably not go higher than 44100 Hz project rate.

And of course, try some other recording application. You could try Ardour but it has a steep learning curve.


Been playing with Ardour for a few weeks now: still trying to figure it out. I will definitely try it if and when I get it figured out.

Like I said before, it just bothers me that I recorded 18 channels before with no problems at all. Now, I cannot. And, I did take the recording hz down to 33, no better.


Well, we got it fixed today: sorta. Reverted back to Xubuntu 14.04 and Audacity 2.0.5 and we recorded 18 channels at 44.1 kHz without any trouble at all. And, right out of the box so to speak: left it at high sampling rate with buffer at 100. Same USB cable as before.

Where is the problem? Dunno. Either Audacity or Linux’s newer versions, but the older versions work fine together.

Well, as an experiment you could uninstall 2.0.5 and install the 2.1.2 “Ubuntu Handbook” PPA for 14.04:

That 2.1.2 is essentially our 2.1.2 release, so is regarded as stable.


I already thought about doing that. And, I will one of these days. After fighting with this for the last month, I am going to forget about it for a little while. :slight_smile:

Thanks to all who tried to help!

I would think that someone can close this thread now. After switching back to the older version of Linux and Audacity, everything has been running fine.

Let me make an observation here: I don’t know what it means, but I am hoping someone here will.

With the newer version of both programs, I noticed that there is no lag time from when I stop recording to when I can give the file a name and save it. With the older versions, there is considerable lag time: 30 seconds or so. When I click on the stop button (when done recording), the PC’s HD light runs for about 30 seconds. After it stops running, I can then save the file.

My guess is this: whatever is decreasing the time it takes for the PC to get done processing the file, is actually running and preventing the PC from properly recording the file.

If I am only copying cassette tapes to Audacity (2 track stereo), I have no issues at all. It is only when I am recording 18 channels that I have issues.