After update 3.4.0: Clicking to join clips not working

Before the update, when there were two directly adjacent clips, I could join them by clicking the line between them.
Now, it no longer works - the cursor doesn’t change shape anymore when hovering over the line
Do I need to enable it in settings? I couldn’t find a setting that sounded like it,

1 Like

That feature has been removed. To join clips, make a selection, then right-click and click “join clips”

Thank you for the info! What a bummer, I was using it constantly.

3 Likes

I also use it frequently.

At least “selecting, then right click, then click on the Join command” is less arduous than using the menu command every time, but it’s still more tedious than just clicking on the split line.

2 Likes

But it was also tedious and annoying when you couldn’t select at the split line (without losing the split!).

Peter

@waxcylinder, I’ve seen at least one other user with a similar complaint, so, you’re not alone in having been annoyed by click-to-join.
I wish they had made this a setting you can check or uncheck instead of removing it entirely. In my work processes, I use it >50 times per hour, that’s a lot of extra clicks to add with the new update.

2 Likes

@S_Von

In which case what I would do is to create a single key custom shortcut for the command Edit > Audio Clips > Join (a few single keys remain available last time I looked).

See: Shortcuts Preferences - Audacity Manual

Then all you have to do is click and drag around the clip join and then press your shortcut key.

Note that if you elect to use the full set of shortcuts from preferences then there is already a shortcut for this command - but it is a 2-key shortcut Ctrl+J.

Peter.

No need to create a custom shortcut, because it’s already defined in the “Full” set of default shortcuts. Just select “Full” as the default shortcuts. The hot key for join is “Ctrl + J”.

Even with the shortcut it is still more tedious than just clicking on the split line because you have to make a selection across the split before pressing “Ctrl + J”, plus it requires moving from mouse input to keyboard input.

“Select, then right click, then click on the Join command” is probably the most efficient method in the current version of Audacity.

I never really understood that complaint. I’d have thought that anyone using splits regularly would quickly get in the habit of selecting “to” a split line rather than “from” a split line. And if you want to select the entire clip, just double click on it. (Purely academic now that “click to join” has been removed for all users).

1 Like

I used this feature extensively too and am frustrated by its removal.

I have never understood why developers remove things, rather than let users choose how they want to do something. Most annoying.

2 Likes

I vote to re-introduce the now gone click to join!!!

3 Likes

I think the reason that it has been removed is because clip boundaries are becoming overloaded with multiple functions, Resizing clips is done from the clip boundary, and now time-stretch by “Alt + drag clip boundary”.

Personally I don’t see why “click to join” can’t be available as an optional feature, though it would need to be restricted to the lower half of the clip boundary so as not to conflict with clip resizing, and the clip boundaries would be quite cluttered with three different functionalities. Also, I think that muse group are intending to add the ability to overlap clips some time in the future.

there is also the waveform RMB context menu

  1. Select around the proposed join(s)
  2. Right-click in the waveform
  3. choose Join Clips from the context menu

Peter

On my Windows PC, ‘Join Clips’ causes stereo tacks to be split into mono.

1 Like

In fact this happens if I drag any stereo audio downwards onto a different track. The destination track becomes split mono.

1 Like

Can you give precise steps to reproduce that?
Also, which platform (Windows / Mac / Linux)?

Windows 10.
Record a stereo cue.
Then [Tracks] [Add New] [Stereo Track].
Drag the stereo cue onto the new tracks.
The cue lands as a split mono track and the new tracks are now mono. The top two tracks sometimes become split mono too.
In Recording Preferences I have ‘Record On A New Track’ ticked.

I’m not able to reproduce it with those exact steps, but there’s some similar steps that do trigger the bug for me in this bug report: Transporting Audio Clips to Other Stereo Tracks Splits Tracks to Mono · Issue #5389 · audacity/audacity · GitHub

Yes that’s definitely the same issue Steve.

No, actually, it is FAR more tedious and annoying not to be able to remove the line and have to take 5 steps instead of 1. Incredibly BACKWARD “improvement” to Audacity. Why don’t you guys do some user testing before deciding your own experiences are like regular lay users?

Agreed – this has added hundreds of extra steps in each editing session now. Flabbergasted, not to mention ticked!
C’mon folks…why make life more difficult for the lion’s share of your users? Hoping that reverting to the previous version of Audacity brings back this functionality rather than this degraded experience…