ACX Check plugin won't load

os x 10.12.2 , Audacity 2.1.2
I download the ACX-check plugin and it shows up as text only. I rename the file taking out the txt and drag it into Audacity plugins folder but it still shows up as text and it does not show up in Audacity under effects or anywhere else. All the other plugins in the folder show up as documents not text, not sure if that helpful but I need to get the ACX check plugin. Any ideas how I do this?

I’ve sent the screen shot of the download and with the download in the file. Thanks for your help.
Screen Shot 2017-02-22 at 9.40.49 AM.png
Screen Shot 2017-02-22 at 9.40.09 AM.png

In case you have corrupted the file I have attached another one.

Have you used Effect > Add / Remove Plug-ins…? Use that, select the acx-check, click “Enable” then OK.

If that does not help, do you see any of those other Audacity plugins such as Adjustable Fade or Crossfade Clips in Audacity’s Effect menu, or Beat Finder in the Analyze menu? If not, make sure at Audacity > Preferences…, Effects section that the “Nyquist” box is ticked (checked).

And if you still see no plugins in Audacity after that, try this:

Acx-check.ny (9.01 KB)

It is a text file in a particular form. It will open in Text Edit.

You can tell Finder (desktop) to hide filename extensions. I think that’s a terrible idea particularly if something goes wrong.
Screen Shot 2017-02-22 at 7.06.49 AM.png
Right-click or Control-Click the file > Get INFO. What does it say?
Screen Shot 2017-02-22 at 7.05.47 AM.png
It is intended to appear under Analyze.
Screen Shot 2017-02-22 at 7.20.11 AM.png

OK! After going through each and every step I had to go to the link you attached to a former post. I had to go into the terminal and enter the code you had listed and it worked like magic!

Thank you so much Gale!

and thanks to Koz for pitching in.


We’re happy you got it to work, but it is a little concerning you needed Terminal to get there…

In the upcoming 2.1.3 release you shouldn’t need to use the Terminal to access the plugins, at least when starting Audacity up.


Had the same issue - tried downloading the Acc-check.ny.txt file from the online instructions ( and dragging it into the library (using Audacity 2.2.2), and it did not appear in the add/delete plugins list. Tried it many times. I finally found this post, and the file Gale attached, dragged it into the library, and everything worked perfectly from there.

Thank you, Gale!

I’m having this exact same problem. In the previous answer, what do you mean by you dragged it into the library? Where is the library?
many thanks!

Go (from the desktop top) > Go To Folder.

Screen Shot 2018-09-07 at 13.06.57.png
Once you get there, audacity > Plugins


Which part did you drag into your library? Three things come up when I click on the attachment that Gale provided. See screenshot below.

I double clicked on the Lame Library package (first icon on the left)
When I try to proceed with the installation, the following comes up asking if I want to intall to my HD or Lame Audacity (which has a caution icon on it and will only let me install to the HD)
So, I install to the HD and a prompt comes up saying it installed successfully
There are already plug ins in my plug-in folder under app support in my library, yet the plug ins still dont show as an option in Audacity

I already copied and pasted the code that Gale recommended into the terminal and that didn’t fix anything.

Suggestions appreciated.
Screen Shot 2019-02-15 at 7.30.40 PM.png
Screen Shot 2019-02-15 at 7.28.00 PM.png
Screen Shot 2019-02-15 at 7.26.37 PM.png
Screen Shot 2019-02-15 at 7.23.32 PM.png

I discovered that Lame was installed correctly on my machine - the entire 10 times I re-installed it. :laughing: I’m sharing my revelation here in case it helps anyone else who is struggling.

In reading various forums, I had thought I was supposed to see Lame show up under the Effects menu in Plug-ins in Audacity, which it never did. I’m not sure where the disconnect was or where more information lies re: how to confirm a successful installation, but I was able to confirm that Lame was installed correctly by doing the following:

  1. Creating a test audio file
  2. Going to ‘File’
  3. Then ‘export’
  4. Then ‘mp3’ will be an export option

If you see mp3 as an option for exporting your file, Lame has installed correctly.

I learned that by simply opening Audacity and selecting ‘File’, then ‘export’, that the ‘mp3’ option is greyed out. You have to actually create an audio file, not just open one in order for the mp3 option to appear.

As for the ACX Check plug in, I was able to successfully enable that in the Plug-ins menu in Audacity after searching my computer for the ‘hidden’ library referenced above. I guess I somehow missed that there were two libraries with the same things in them so I kept dropping ACX in a folder that looked exactly the same as instructions described, yet it wasn’t the right folder.

Thanks everyone who helped me complete these tasks.

If LAME is not installed correctly, then there will still be an “option” to export as MP3, but the export will fail, with an error message to say that LAME could not be found (so this method does indeed let you know if LAME is correctly installed).

Another way to check if LAME is installed, is to look in “Preferences > Libraries”
If this shows a version number for LAME, then it is installed correctly. If it says “Lame library not found”, then LAME is not installed correctly, or is installed in a non-standard location and Audacity can’t find it.

I’m hoping to make this easier in the future, though it is unlikely that this improvement will make it into the next release. I’ve written a small utility plug-in that can install Nyquist plug-ins into the correct location, just by selecting the “.ny” file and clicking “OK”. As this utility is itself a Nyquist plug-in, it is only really useful if it is included with Audacity by default, otherwise users will have exactly the same problem installing it as they do installing other Nyquist plug-ins.