Access old Audacity files

My mac OS is 10.15.5 (Catalina) and I just updated Audacity to version 2.4.2. Is there a way to access (load, play) things I recorded on the previous version of Audacity? I tried just importing the .aup file to no effect.

Should be perfectly possible.

You don’t Import an AUP project tou File>Open it.

Plus there are two parts to a project: .aup and its related data folder _data
both of these must be present and co-resident in the same folder.


Well, yes, I wanted to click on the file. But when I tried the Open File menu the .aup file was greyed out. So I tried workarounds. To no avail.

Okay, I just tried something and, obviously, I must be stupid because I can’t get things to work right.

I just made a test recording for a few seconds and saved it to my desktop. Clicking on the .aup icon does nothing – as opposed to the way Audacity used to work. On the File drop-down menu the aup file on my desktop is greyed out, so I can’t open it. On the file drop-down menu the Open Recent file does list my test file and clicking on that aup file opens the recording. So, is that the ONLY way to access a recording? What if it’s not a recent file?

What am I doing wrong?

What do you mean by “the File drop-down menu”?

In Audacity if you do File > Open, then a standard file-open dialog should appear, and the .aup files should be available. This works for me on Catalina and Mohave with Audacity 2.4.2.

Double-clicking an AUP file in the Finder (or right-clicking then “Open”) does not work - this is a known bug.

– Bill

The drop-down menu is: New, Open, Open Recent, Close, Save Project, Export, Import, Page Setup, Print.

As I said, using Open shows the aup file greyed out – even on my test recording, let alone an older one. Only the Open Recent option allows me to open that test recording. It shows not just the file dot aup but the complete computer location: users/michaelspielman/desktop/test.aup (and do on).

I cannot reproduce this and I’ve never heard of anyone having this problem. Maybe one of the other forum elves will have some insight.
– Bill

My fervent hope. Thanks.

Click on the “Options” button in the file browser, and select “All files” as the file type.

(This “feature” is one of the worst design decisions I’ve ever seen from Apple)

No kidding! I never touch that “Options” button. Hiding the file type filter drop-down is crazy.

– Bill

Sorry, you lost me: What Options button? What is the file browser? Clicking on he file menu shows no “options” button. Help.

Click the “Options” button to reveal the “File type:” menu. Choose “All files”.


That did it! Thank you so much – I never would have thought of that.