-9997 error won't let me use audacity


I tried to follow the last recommendation and follow the dictates of the manual.

Unfortunately, every time I try to get started I see: “Error opening recording device. Error code: -9997 invalid sample rate”

I really want to be able to use Audacity. Please tell me how to get over this hump.

What are you trying to record?
Which version of Audacity (look in “Audacity menu > About Audacity”).
Which version of macOS?

I have same issue. I am using OS 10.14 mojave. I am trying to input from a Super USB Cassette capture.

In the “Audio Midi Setup”, what is the sample rate set at for the cassette player?

See this page in the Audacity Manual: https://manual.audacityteam.org/man/error_opening_sound_device.html



I’m also having the same problem, with “Error opening recording device: Error code 997: invalid sample rate” when trying to record.

I’m running MacOS High Sierra version 10.13.6 & am trying to record from a Super USB cassette capture.

When checking the Audio device set up on my Mac I can see that the external USB device is set to 48,000 Hz whereas (I’m guessing) it needs to be 44,100 Hz - yet there is no option to change it (see screen shot).

I’ve been SO excited to record my old mix tapes to MP3’s and am now fed up & frustrated :frowning:

Any guidance most gratefully received!

Thanks in advance.
Screen Shot 2019-08-21 at 14.44.53.png

The “recording” device is the “Input”. Your screenshot only shows the “Output” settings.

I’m trying to record cassettes.
It’s audacity 2.3.2, which I just purchased from Amazon.
My Mac is running 10.14.5

Every time I follow the instructions, all I hear is loud feedback.

I’ll bet you’re using one of those cassette-to-USB mini players that sell for about $30 on Amazon.

Lots of people have trouble with them. They show up as a “PnP Audio Device” instead of a “USB Audio Device” in System Sound Preferences. We’ve not been able to find a consistent fix for this issue.

One thing to try is to have Audacity open, start the cassette playing, then select the “PnP Audio Device” as the Recording Device in the Device Toolbar, then click the Record button.

It’s audacity 2.3.2, which I just purchased from Amazon.

I hope not, as Audacity is free and open source and can be freely downloaded from here.

If you are getting howling feedback, that suggests that you have the Mac’s internal microphone chosen as the input device.

– Bill

As Bill wrote, Audacity is free software. However, if you bought Audacity, I’d suggest that you contact the seller and ask them to either help you fix the problem, or give you a full refund.

Please note that we can only provide support for the official version of Audacity (free, via: https://www.audacityteam.org/download/). We have no way of knowing if versions from other places have been modified.


I had the same problem. I am using Windows 10.

I fixed it going to Control Panel > Sound > Recording TAB

In here right click and click on “Show Disable Devices”

Now enable something called “Stero Mix”

I hope this helps you.