4 minutes of blank space before a track, can't remove

windows 11 home, build 3.1.3
i recorded a track, originally it had no blank space before it. i had been using the draw tool to smooth out some places and somehow or another wound up with over 4 minutes of blank space before the track, although only 32 secs or so of the blank space tries to play. the cut tool does not get rid of it, any ideas how to remove it?

zoom out a bit, then grab the audio by its clip handle and move it to the start

Or go to Edit >Preferences>Import/Export and check “on” Ignore blank space at the beginning

Alternatively just select the range of audio you want and use File > Export > Export Selected Audio…