2.3.1 WASAPI inconsistent recording, volume dependent on system volume

(Windows 10)
Hello, I’m having issues with recording system audio using WASAPI. I’ve gone up and down the internet, found some forum posts, but have been unsuccessful. This is my last resort.

TL;DR: 2 issues, both with WASAPI

  • when recording system audio with headphones plugged in, the recorded audio volume level is dependent on the system volume level (i.e. I will only get a full volume recording if the system volume is all the way up).
  • when recording system audio without headphones plugged in, this solves the weird volume linking (i.e. the recording will have constant max volume regardless of system volume), but seems to only capture stereo information…

More details…

This one happens when my headphones are plugged in (output jack, not USB). These are my settings
Audio Host - Windows WASAPI
Recording Device - HeadPhone/Digital Output (Realtek High Definition Audio)(loopback)
Playback Devices - HeadPhone/Digital Output (Realtek High Definition Audio)

In this mode the volume slider for the recording device is locked at 100%. The volume slider for the output device is the same as whatever the overall system volume is. When I record this way, the recording volume is dependent on the system volume. I only get full volume recording if the audio on the system is all the way up. This isn’t practical with headphones on…

Trying to find a workaround, I unplugged my headphones (audio now coming from laptop speakers), and set my settings to:
Audio Host - Windows WASAPI
Recording Device - Speakers (Realtek High Definition Audio)(loopback)
Playback Devices - Speakers (Realtek High Definition Audio)

At this point, the sound records at full volume regardless of the system audio level (I double checked, brought the volume all the way up and all the way down, the recording maintained its volume). BUT, the audio sounds different to the source, almost like it’s not including any mono information or maybe the just capturing the higher frequencies.

The disparity is almost like (if not exactly like) the one posted here:
To my knowledge, I don’t have any ambiental or spatial effects turned on.

What can I do? I’m pretty frustrated… ideally I’d want to be able to record at a constant volume with headphones on, and have that recording be accurate…

It’s been a few days and no response, thought I’d bump… Is there any other information I can provide that would be useful for resolving this issue?

I tried recording with the volume all the way up and the headphones muted and that worked, but then I’d have to listen back afterwards. This pretty much doubles the amount of time it takes to record, so isn’t too practical.

Right now I’m just normalizing the lower level volume recordings. The noise level seems low enough, I’d still rather not have to take that extra step, but oh well. For anyone trying this in the future that’s just ctrl+A, Effects > Normalize

In the Manual on this page:

It says

Windows WASAPI: This host is the most recent Windows interface between applications (such as Audacity) and the audio interface driver. WASAPI was first officially released in 2007 in Windows Vista. WASAPI is particularly useful for “loopback” recording of computer playback. 24-bit recording devices are supported using this host. Playback is usually emulated. As a result, the playback slider in Mixer Toolbar will only scale the system playback slider’s current level up or down rather than directly manipulating that system slider.

I can’t experiment right now as I am away from my production environment - I’ll try to do some testing in a couple of week’s time when I get back home.