2.1.0 install fails with version error

I do not see any separate x86 and x64 versions, but on my Windows 7 x64 SP1 system, the file from standard download location


gives the installation error

“The version of this file is not compatible with the version of Windows you’re running. Check your computer’s system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.”

Audacity for Windows is only available as a 32 bit application.
Windows 7 x64 SP1 should be able to run 32 bit applications. Have you tried running it in compatibility mode?

I’ve never seen this error before. I run 32-bit apps all the time without any special installation. It sounds like the Audacity 2.1.0 installer was built with an incorrect setting somewhere.

Audacity 2.1.0 for Windows has been built with a later version of Microsoft visual studio. If your computer does not have sufficiently up to date run-time libraries, that could account for the problem.

The developers were wanting to avoid breaking support for Windows XP as there are still such a high percentage of people using the obsolete operating system, so the build options in VS2013 were selected to allow Audacity to continue working on XP, therefore Audacity 2.1.0 should be compatible with all versions of Windows from XP SP3 onward.

I rarely use Windows, so I’m not really the best person to help. No doubt one of the Windows guys will be along at some point, but in the mean time I think that it could be worth you trying compatibility mode. Have you tried that?

I have just installed Audacity 2.1.0 as available from http://www.fosshub.com/Audacity.html/audacity-win-2.1.0.exe on Windows 8.1 64 bits with all MS updates.
No problem to report. Everything went fine. There was no need for any compatibility mode. I installed it into the default “C:Program Files (x86)Audacity” folder.

I install all my Audacities alphas, RCs and now 2.1.0 in the C:Program Files (x86) running on my W7 64-bit laptop and they all run just fine - so I’m puzzled :confused:


The installer was tested on a number of our Windows 7 x64 systems.

Do you have an older version of Visual Studio than VS2013 installed?

What I would suggest is installing the VS2013 32-bit redistributables, restart the computer and see if that helps.


Thanks for the suggestion, but it did not change the error dialog shown at the start of installation. Here’s more info:

Audacity 2.0.6 is still installed and runs fine. It installed without problems last fall.

Per your suggestion, I followed your link and it installed
Microsoft Visual C++ 2013 Redistributable (x86) - 12.0.30501
and I rebooted.

The following were previously installed, and still are installed:
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161
Microsoft Visual C++ 2010 x64 Redistributable - 10.0.40219
Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219

Does your 2.1.0 folder contain the required msvcr120.dll and msvcp120.dll?

You could try uninstalling those one by one, starting with the “9.0.30729.17” copy of 2008 x86, then see if Audacity launches after each uninstallation.

I appreciate some other application may want the older redistributables, but doing that will at least give us some quick diagnosis.

Do you have Visual Studio itself installed? It’s Microsoft’s app for compiling source code.


OK, I figured out the problem. When I go to
and fly over “Download Audacity 2.1.0”, it shows
so I should be able to right-mouse “save link as” and then run the result, right? Nope! That gives you a 58KB file instead of the actual software installer. I clicked through the link instead, and that gives the correct result, which installs and runs correctly.

No, that is not the intention because the link redirects to the web page of the FossHub trusted download partner before popping up the download box for the installer.

I don’t know what browser you are using but it should “Save as” that link as an HTML document, which you couldn’t execute.