Zoom H2n mic/line choices [SOLVED]

Audacity version: 2.0.6, distribution release
System: Bunsenlabs (lightweight distro based on Debian Jessie)

When using ZOOM H2n microphone via USB, Audacity gives the following choices for device H2n: USB Audio (in Edit → Preferences: Devices):
Front Mic:0
Rear Mic:0
Front Mic:1
Rear Mic:1

I’m wondering what these mean with this microphone and how they relate to the recording settings of the microphone itself (2ch/4ch surround, MS, XY)?

That looks like your computer’s built in sound card.
When you connect the mic it will prompt you to select “Mic” or storage device. Select the mic option. I think it may then prompt you to select the “Sample Rate” - if it does, select 44100. When that’s all done and the mic is connected to the sound system, launch Audacity (not before). You should then see a USB option in the device toolbar - I think you only get mono/stereo available, and to select front/rear is done on the mic not the computer (check the H2N manual for details).


Ah, I thought I didn’t have to go the preferences to select the mic when I used it with Audacity some years ago, but I couldn’t find the toolbar this time. Now that I know what the toolbar is called, it doesn’t seem to have anything to select on it, picture (don’t know from where that shadow came from): http://i.imgur.com/FESs4EV.png

The mic is connected to the computer in the audio interface mode. It seems I can use it by selecting any of the options via the Preferences, though it still doesn’t show in the device toolbar.

The shadow is because the toolbar has been dragged out of its dock position (it is now a “floating toolbar”). You can reset the toolbars to their default docked positions with “View menu > Toolbars > Reset”.

Have a look in “Help > About Audacity” and go to the “Build Information” tab. What does it say is the WxWidgets version?

Alright, the WxWidgets version is 3.0.2.

As I expected, Bunsenlabs have built Audacity with the wrong version of WxWidgets. See: http://wiki.audacityteam.org/wiki/Incorrect_wxWidgets_Version

The PPA version mentioned in that page is designed for Ubuntu and derivatives, but ‘may’ work with Bunsenlabs. The better solution would be to build Audacity from the source code. As Bunsenlabs uses Wx3.0.2, it would be easiest to build the current 2.1.2 version of Audacity, or for less bugs, the current 2.1.3 alpha (available from GitHub).
These instructions should be pretty close : https://forum.audacityteam.org/t/building-audacity-2-1-2-on-ubuntu-15-10/40680/1 but I’d suggest using the 2.1.3 source code, downloaded as a Zip file from https://github.com/audacity/audacity

You may also want to report the problem to Bunsenlabs.

Okay, I succeeded in building 2.1.3alpha from source (with libflac disabled).

The device toolbar works now, although it has the same options as Preferences: Devices, picture: http://i.imgur.com/nGWFlZS.png

It doesn’t seem to matter which one is chosen and recording works.

Thanks for the help.

Thanks for reporting back. We’ll mark this [SOLVED] then.