Zero crossing not working

Hello everyone,
I use Audacity 3.1.0 on Windows 10 and on Linux and this issue is the same in both O/S’s. I’m currently editing an audiobook and regardless of whether I hit the “z” key or select zero crossing from the select menu, I still hear an audible click at the edit point. I have to manually zoom in and select a zero crossing, or use a crossfade (doesn’t always work), or use the click remover.
Many years ago, I did all my audiobook editing in Soundforge. It had an option in the preferences to always edit on zero crossings. It was great because it was seamless. You clicked where you wanted your edit and it automatically adjusted the edit point to the nearest zero cross. It always worked. Oddly, the latest version of SF no longer does this, nor does it have the option in preferences. It amazes me how software takes backwards steps.
With that said, is there any way edit selection points could be made to happen at zero cross points automatically in Audacity? I can’t think of any reason why one would NOT want to edit on a zero crossing point. If not, is there a fix for the current situation?

I use Audacity 2.3.1 and cut on zero crossings works well, perhaps it’s a newer version bug?
I’m sure one of the mods will confirm if this is the case, as I don’t believe it was taken out intentionally.

It amazes me how software takes backwards steps.

Absolutely, it’s amazing how many well known software applications and even OS’es are guilty of this.
I always wonder what they are thinking.
As for SF, I briefly tried version 15, hated it, deleted the trial version after just the second day.

A zero crossing alone doesn’t guarantee a click-free world, for example, if you have a steep drop in the waveform on one side and a steep upwards slope on the other, it still might click.

Can you confirm that when zoomed in and using z for a zero crossing, it actually did select a zero crossing? because it’s doing it for me.


Are you using the new looping feature? if so, that doesn’t yet support snapping to zero crossings, so your selection actually might be properly selecting, but the loop just isn’t. As a workaround, once you’ve made your selections at a zero crossing, you can right-click the timeline ruler above the waveform and click “Set loop to selection”.

And lastly, a shot in the dark: You don’t have any DC offset which would get in the way of things, do you? Did you try to normalize the audio first?