I’m hearing that the new version 2.0.6 is not compatible with Yosemite. Is this correct?

To be clear, if I stick with the previous Audacity version and upgrade to Yosemite, will I be alright?
Also, I’d hope that work is being done to make 2.0.6 and Yosemite compatible?

Thanks for any info. I’m fairly new to the Mac world, not real fond of Garageband, and don’t want to lose the ability to record my podcast.


Total Babble Podcast

I’m not a Garageband fan, either.

This is an actual broadcast sound shoot with Audacity.


If you are upgrading an earlier OS-X, I would generate a very compelling reason to do so. Blindly upgrading “because it’s there” can be a very poor decision. I’m still recovering from the software that stopped working from the Mavericks upgrade.


Correct. Audacity support ends at OS X 10.9.x.

Your risk. There is no official support for Yosemite. We believe that Apple Audio Units will not appear when you request them from the Audacity Effect Menu.

None at all directly, because we don’t have the resources at present.

It’s thought many of the problems with Yosemite are because it is making greater use of Cocoa. Cocoa has very little support in the version of the wxWidgets interface toolkit that we currently use. So the first task (which is being worked on) is to upgrade Audacity to the current stable version of Widgets which has better Cocoa support. That in itself needs a lot of work.

Nonetheless, if you do decide to use Yosemite when released, please feel free to let us know of any issues you find.


Thanks very much for the info! Appreciated…

He wasn’t joshing. This is a forum where you can share experiences and if you do have any experiences with that combination, good or bad, it would be nice to know about them. Koz

I don’t use any “Apple Units” in my audio recordings that I know of. I use Audacity quite a bit when recording my dj sessions from vinyl records, or simply digitizing a track from a vinyl record to make a mp3. Will I be ok to that to do if I upgrade to Yosemite? Digitizing vinyl isn’t really using Apple units. I guess the larger question would be after I save as mp3 will I still be able to import them into my itunes library.

As stated, there is no official support for Yosemite. It would help us if you report behaviours you encounter (what works and doesn’t) but the risk is yours.


I’m torn. I love the simplicity of Audacity (I have 2.0.5) and I’m running Snow Leopard 10.6.8. I’ve resisted upgrading to any new OS X for years but as you probably already know Snow Leopard users are a dying breed. At some point I’m going to have to upgrade as support is long gone. I just use your program quite a bit and would have to not be able to use it to record and digitize vinyl anymore. It’s a case of “it’s not broken why fix it?” but for how long. If I do upgrade I’ll let you know.

Apple are going to make it hard to find Mavericks now, but you could upgrade to that. You would do Apple Menu > Software Update to make sure you have all the latest Snow Leopard updates then see if you can find an update installer for Mavericks. I think Mac OS X Mavericks Download Free - 10.9.5 | TechSpot would work, but it’s your risk, and I would ask on any of the Mac specialist support forums online if you are unsure.


I tried to edit and save an existing recording. as soon as the export is pressed its spins forever…

Make sure you are exporting a location you have permissions to write to.


I can confirm that AU and VST effects do not open windows on Yosemite. The other thing I noticed is there is some flickering of various components of the GUI, like the time ruler etc. Otherwise it seems to work.

OS-X 10.10
Audacity 2.0.3

Came here to find out about Apple plugins not working after recent Yosemite upgrade. So far everything else I use works (import/export, basic plugins).

Thanks, Jams. However 2.0.3 is obsolete now so I suggest you get 2.0.6 from Audacity ® | Download for Mac OS .

Generally, AU made by third-parties other than Apple should open from the Effect Menu in 2.0.6.

Generally, VST should do likewise in 2.0.6.


I just finished recording a record on my Macbook via USB. I’m using OS 10.10 Yosemite and Audacity 2.0.6. I used fade in, fade out, click removal, and normalize. All worked fine. I exported multiple files in uncompressed 32 bit Aiff to itunes and it worked the same as always which is a good thing because I love Audacity. If you are just recording all your vinyl to itunes like me there are no problems. All you programmers involved with this deserve a big THANK YOU.

Thank you for that, zpalma. :slight_smile:


I literally can’t get Audacity to run properly on Yosemite: when I press the record button, it will record for about one second, then stop, and may or may not start again!

If you have a selection lasting one second Audacity will by default record for one second.

Have you tried Audacity > Preferences, Recording section, then increased “Audio to buffer”? It should be set to 100 milliseconds by default.

If that is not the problem, please tell us what exactly you are trying to record, how your recording equipment connects to the computer and what your choices are in Device Toolbar.


We’ve attempted to fix Audio Unit support on Yosemite. Audio Units should also support real-time preview and user and factory presets.

Testing and feedback would be highly appreciated. The changes will be available in the next Nightly Build (that is, 26 November 2014 03:15) from the top of http://www.audacity.homerow.net/index.php?dir=mac/&sort=date&order=desc.


Hi Gale,

Has the new build been posted yet? I can’t see it in the folder you linked.